Best answer

Can't connect zapier to Wordpress - error 406

  • 31 July 2023
  • 6 replies
  • 160 views

Userlevel 1

Can anyone help with this error? Permission is allowed
Thank You in advance!

icon

Best answer by SamB 2 August 2023, 16:50

View original

6 replies

Userlevel 7
Badge +11

I’m so sorry for missing your reply here previously, @Rodingios! Really glad to hear disabling ModSecurity helped. 🎉

With that feature turned off any security measures it was implementing on your website will not be running. So if you’d prefer to have those security measures running it may be better to try adding Zapier’s IP addresses to your allowlist so that it’s not blocked when ModSecurity is enabled again.

That said, there are a lot of IP addresses that would need to be added so it may be easier set it to allow this User-Agent: Zapier header. Zapier’s calls will always include that header so that may be a simpler option. 

Let us know if you have any further questions at all! 🙂

Userlevel 1

Thank you very much! Disabling mod security helped.😎

I'm just wondering what the secure page looks like now if it's disabled?

Userlevel 7
Badge +11

Hi @Rodingios

I did some digging and it seems the reports of ModSecurity causing a similar 406 error was down to a ModSecurity module/setting being enabled on the web hosting server for the WordPress site. 

Can you take a look at the settings for your web hosting server (or reach out to your website administrator) to see if there’s a similar security setting enabled that might be blocking Zapier’s access here? 

If it is and it’s not going to be possible to disable that setting, you may need to add Zapier’s IP addresses (AWS us-east-1 IPs) to the allowlist in order for the server to allow the connection to be added. You can read more about how to use those IPs here: Can't access or use Zapier with other apps

Hope that helps. Please do keep us in the loop on how you get on here! 

Userlevel 1

I reseted webiste, have only Zapier plugin and still have the same problem. Any ideas?

Userlevel 1

Strange because i don’t have any of this security plugin yet. 

Userlevel 7
Badge +6

Hi there @Rodingios,

Welcome to the Community! 🎉

It seems like the 406 error message you encountered on WordPress could be caused by a security plugin like ModSecurity. These plugins sometimes trigger such errors.

Would you mind trying to deactivate the security plugin on WordPress to see if that resolves the issue?

Please keep us posted! 😊

Reply