Best answer

Airtable error: None is not type ‘integer’ Failed validating ‘type’ in schema

  • 11 August 2022
  • 5 replies

I have had a zap run error out due to a failed “Find Record in Airtable” step. When I try to test the relevant step in the draft I get this odd error message that I have never seen before.



I have tested my Airtable account’s connection within Zapier which returned a successful result so the issue doesn’t seem to be there. 


I have also run a test with the Airtable API for searching the exact same record as the failed zap and that has also worked fine. 


Wondering if anybody would be able to shed a light on what this issue is and whether it may just be a temporary error. 


It may be worth noting that I have had a successful run since this error.


Best answer by christina.d 13 August 2022, 00:18

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +9

Hey there, @danicetoinc!

Out of curiosity, is there a Formatter step associated with this zap anywhere? If there is, are you still running into this error?

Our team identified a bug with all Formatter zaps resulting in this error yesterday. That said, the bug has since been resolved so I’m hoping this zap is up and running for ya by now.

Keep us posted! We definitely want to make sure you’re all squared away here.

Hey, @christina.d 


Yeah there is a Formatter step in the zap and as you said things seem to have returned to normal. 

Thanks for the help!

Userlevel 7
Badge +9

Whoo! 😅 Glad to hear it!

Thanks for letting us know!

Userlevel 7
Badge +9

Hi @danicetoinc 

Not sure if you are using a formula in that Find Airtable Record action, if you do, the error message is saying that whatever you supplied in the formula should be a integer or number, and it seems like you supplied a string None.

To assist further, share screenshot of the your find airtable record action setup page.

Hey @robschmidt, thanks for the quick reply!


I am using a company’s name for the search value (ex: Acme LLC).


Of course, makes sense here’s a screenshot of the relevant step. And just FYI I have also tested swapping the “Search Value” with the relevant Record ID and still get the same error when testing.