Best answer

Zapier -> Database: Dropdown menu items sent as number

  • 5 February 2021
  • 4 replies
  • 125 views

Hi!

I’m using Zapier to update fields in Clio, essentially a client management database for law firms. I don’t believe any knowledge of Clio is necessary for this problem.

My goal is to update a client’s case info using Zapier when an attorney selects an option in Google Forms. I have everything working, and most of the information transfers perfectly. However, if the information sent by Zapier needs to update a dropdown option, it sends a number to the database field instead of selecting the correct text string. 

As a workaround, I have been able to set up a filter in Zapier where if the number being sent = {this number}, then send {this text}. However, this requires running every possibility of dropdown options to discover the numbers, and is simply not a realistic solution.

I haven’t been able to find any similar issues described in the forum. Does anyone know what could be going on here? 

Thank you for your help!

icon

Best answer by automatedLawFirm 18 February 2021, 22:50

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +11

Hi @automatedLawFirm!

Great job figuring that out! It’s definitely not convenient to copy all of those IDs when you have a lot of them. Thanks for sharing that with the Community :)

Just in case anyone else ever has this problem, here’s how I finally solved it! Other options may work too, but these are the specific settings that worked in this case.

In an action step, select “Update Matter in Clio.”

In a field that has a dropdown menu in Clio, click the option on the left (not “Custom”). Each code is listed beneath the corresponding option! I had to write all of these down in a document so that I could copy and paste them into the lookup table.

This was a rather unintuitive place to find the codes, since in this case I needed an option from the “Custom” menu to send the correct information to Clio.

Here is how I set up the options in the formatter step:

and then in the lookup table:

In this case, I needed to put the text on the left and the codes on the right. 

Now that I have all the right codes, everything works perfectly! 

Userlevel 7
Badge +12

Instead of multiple filters, try using a Lookup Table to map a number to the correct text field instead. https://zapier.com/help/doc/how-use-formatter-functions

i am assuming the number is being generated from the Google Form submission? If so, how is the Google Form dropdown set up? 

Thank you, @GetUWired! I have tried this, but my problem is a little different.

The number seems to be generated by the Clio database itself. In the Google Form, users can select an option from a dropdown menu, and that is sent with the other data to the form responses sheet. From there, the information is sent into the Clio database.

Anything besides dropdown menu selections works just fine being sent into Clio, however, any dropdown menu item is converted into a seemingly random code during that transfer, and there are too many options to make a full lookup table with all the possibilities.