Best answer

Zap running twice within seconds

  • 15 April 2021
  • 3 replies
  • 814 views

We have a zap that runs when a record is updated, if a particular field is set to yes then it copies a document to another table.  This was working fine until a few months ago and now it runs twice every time and copies the file twice, I see in the log file that it ran twice within a matter of seconds.

Has anyone else experienced this issue?

icon

Best answer by SamB 9 September 2021, 10:29

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +11

Just to follow up on this one, it looks as though our Support team were able to identify the cause of the issue. It was related to an existing bug with the Caspio Cloud Database integration where updated records are triggering twice. @ELN24 was added to the bug report for this issue.

For anyone who may also be running into the same issue, please contact our Support team. They’ll be able to dig into the logs for your Zap to confirm whether you’re being affected by the same issue and add you to the bug report as necessary.

In the meantime, there’s an article in Community for a workaround to help with duplicate triggers that may be worth trying while the bug is still active:

 

Userlevel 7
Badge +10

@ELN24 
Just checking in to see if you still need help with this? 

Userlevel 7
Badge +14

Hi @ELN24 

What is the Zap trigger app?

 

Might be best to open a ticket with Zapier Support for them to troubleshoot further: https://zapier.com/app/get-help