Question

Wordpress Connection Expires

  • 7 December 2020
  • 6 replies
  • 542 views

Userlevel 3
Badge +2

I am getting repeated reconnect messages from a Wordpress connection.

I have the site connected and data is flowing.  Then I get e reconnect notification after between 2 minutes and 3 days!  Something it will not reconnect.  Other times to reconnects immediately.

Is there a WP setting somewhere?

Thanks


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +14

Check this support article for getting started with WordPress and Zapier: https://zapier.com/help/doc/how-get-started-wordpress-zapier

Check this common problems article: https://zapier.com/help/doc/common-problems-wordpress#500-internal-server-error-or-other-trouble-connecting

500 Internal Server Error or other trouble connecting.

In order to connect to WordPress, you must have XML-RPC functionality turned on. This is turned on by default in WordPress 3.5+. If you're having issues connecting, go to Settings > Writing > Remote Publishing and check the checkbox.

You may also receive this error if your WordPress installation is secured and not publicly available. Unfortunately, the installation must be publicly accessible to work with Zapier.

Also, we're unable to provide IPs to allowlist as our IPs are not static - they rotate because we use AWS. If you'd like, you should be able to allowlist a block of IPs from AWS to make this work. You would just need to make sure the list you're allowing is the us-east-1 IP range.

AWS provides a list of their IP address ranges at https://ip-ranges.amazonaws.com/ip-ranges.json. You can read more about how to use those IPs here.

Additionally, Zapier's calls will always include the header User-Agent: Zapier, so this may be an alternative when allowing a whole range of IPs isn't feasible.

Hey @Davidh88,

Did this fix your problem?
I’m having the exact same issue and I can’t work it out.

XML-RPC is switched on, but having the exact same experience where authentication only lasts anywhere from a few minutes to a day.

Userlevel 3
Badge +2

After much fiddling doing nothing more then reconnecting, it now seems to be stable!

Go figure

Userlevel 3
Badge +2

I am running WP 5.6.  There is no checkbox for XML-RPC under setting.  No checking with hosting it is turned off.  They turned it on and hopefully that was the issue.

 

 

Userlevel 3
Badge +2

Thanks Troy.  The bit I had missed was creating a specific Zapier user account.  I hope that was the problem.

 

 

How odd!
I ended up getting a reply from Zapier support, who told me that I could try using the legacy integration with Wordpress to see if that fixes the issue. I changed to the legacy app connection in my Zap and 2 days later it still seems to be holding up just fine.
 

Just thought I’d leave this here for anyone who has the same issue. You can potentially fix it by swapping to the ‘Wordpress (Legacy)’ connection in your Zap :grin: