Best answer

Using Zapier to set a reference field within a Webflow CMS item.

  • 19 May 2020
  • 9 replies
  • 1599 views

Userlevel 1

Hello there, 

How could I use Zapier to set a reference field within Webflow’s CMS? 

I’m building a membership website.

When new members join, a unique item is created in the Members CMS collection.

They also go through several forms during the induction, stating their interests and what they want from the membership. The answers to each of these forms our in their own CMS collection, a unique item is made for each member who submits their response. 

So far so good, but:

I’ve used reference fields in the central Members CMS collection, thinking that I could use Zapier to automatically link to the member’s answer-groups CMS items.

But this clearly isn’t the case, so I hoped something could be fixed or that you might have a work around for this?

Ideally, I don’t want to use any other apps other than Memberstack, Webflow and Zapier because the costs of a dozen subscriptions are adding up.

Please let me know what yous suggest.

Best regards,
Merlyn.

icon

Best answer by Danvers 11 August 2020, 14:40

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

9 replies

Same Problem here -.- No chance to map reference fields 😫

 

Idk what this means, especially “item ID”: 

“but it looks like mapping the item ID in the Item field should do the trick here”

Hello! I believe that I have same issue. I keep getting Validation Error: Validation Failure. I have a single reference field as a select field and I also put the items into the select field in the form. However, I keep having this issue.

 

How can I map the ID item into the ID field so that, every time that my customers select one option, it is automatically recorded to the CMS?

 

Thank you in advance!

 

I just tested this and you can pass a single reference field into webflow via Zapier. Here’s what mine looks like: https://d.pr/draw/rXA8Gk/

I’m interested in this as well.

Mappings are working for multi-reference, but not reference fields in Webflow.

 

Thank you.

Userlevel 7
Badge +12

Hi @JakeCaggige! We don’t have a definitive answer, but it looks like mapping the item ID in the Item field should do the trick here. If that works it would be super helpful if you could swing back here and let us know!

 

If that doesn’t work then the best thing to do is to reach out to the Support team using the Get Help form

Hello, I am currently looking for an answer to this question as well. Was a solution figured out?

Userlevel 7
Badge +8

Hi @samthorntonj ,

Thanks for reaching out! Could you try mapping the item ID in the Item field and test your Zap again? 

Let us know if that doesn’t do the trick and we can dig deeper!

Hi, I’m having the exact same issue and would like to get help!

Userlevel 7
Badge +11

Hi @Merlyn.Em!

Looks like you’ve got a great conversation going with our Support team and they’re helping you out with this! If you have any further questions you can reply to that thread :)