Best answer

Slack does not show bot icon

  • 10 November 2020
  • 5 replies
  • 1496 views

Userlevel 1

When I post a test message the icon that I created for the bot never shows up. Its stays empty, doesn't show zapiers logo as well. 

I tried multiple times different icons and URLs and it stays still empty. :) Does anyone have the same issue? Would be so happy to get advise.

icon

Best answer by andywingrave 22 November 2020, 18:28

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +14

The last time this happened was due to a Slack update.

Zapier has some incidents today but not sure if that’s related.

https://status.zapier.com/history

Userlevel 1

Mhhh ok but today slack is still not showing the icon after I tried it a few more times 

Userlevel 7
Badge +8

Hey @JKoe - Is this still persisting for you? Please clear your cache in Slack by doing: Help > Troubleshooting > Clear cache and exit

Please let us know if you still need help!

Userlevel 7
Badge +9

I’ve run into this a few times before. Have you checked that your syntax is correct. I believe you need to include the colons like :this: for example.

 

Let us know if it’s still happening with a screenshot of your set up and the resulting image in Slack please.

Userlevel 7
Badge +8

Another consideration is: If you remove a emoji from your Slack instance (or even remove the alias to an emoji) your bot icon will disappear or you’ll have the default icon for Slack in place of it. I found this out yesterday myself. :joy: