Question

Read Receipt in Email by Zapier not triggering

  • 13 May 2021
  • 5 replies
  • 250 views

Userlevel 1

This is one of the strangest issues in Zapier. The Read Receipt has to start as a trigger in a new zap. But the Read Receipt is never found though I am following the documentation step by step. I’ve tried immediately after sending the outbound email (with Email by Zapier), trying after a few minutes, sending the outbound email as a test trigger, sending the outbound email with different trigger. This Read Receipt can never be found. 

Can anybody help? Thank you


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +11

Hi @morariu!

Apologies for the delay in getting back to you here. I figured out how to get this to work, and will be making some suggestions to the product team about how best to explain to users the proper way to test this and get a live sample.

Here’s what I did:

  • I created a Zap with the Email by Zapier ‘New Read Receipt’ trigger
  • I skipped the test and used dummy sample data:

     

  • I added my action (which was to email myself to let me know this worked)
  • I turned Zap #1 on
  • Next, I created another Zap
  • I used our Chrome extension’s ‘New Push’ trigger so I could easily make this Zap run (little tip there)
  • I added the Email by Zapier ‘Send Outbound Email’ action, with the Enable read receipts option set to TRUE (I’m sure you know this)
  • I turned Zap #2 on

This next part is what’s not at all obvious:

  • I triggered Zap #2, sending myself an email
  • I opened that email, in order to then trigger Zap #1 (the one with New Read Receipt as the trigger)
  • Once I saw that the Zap triggered properly then I re-tested the trigger step and was able to get my live sample

So essentially you need to have both Zaps on, do something that would trigger the New Read Receipt Zap and then test to get live sample data. I’m going to recommend to our team that we make it more obvious in the Zap editor, or maybe change the behavior since that was the only way I was able to get this to work.

Hope that helps, and so sorry again for the frustrating experience!

Userlevel 1

The support is almost non-existent. On a paid account nevertheless. I opened a support ticket asking for help, mentioning the zaps, the exact case, etc. Zapier’s support response was that I must click a button. This is rather insulting and not helpful whatsoever. The support person must have not read the details.

 

Userlevel 1

Hi @morariu 

Might be best to open a ticket with Zapier Support on this issue: https://zapier.com/app/get-help

Thank you. I’m building the zap for my company. Support responses would go to a different email address, which I don’t have access to right now. 

Userlevel 7
Badge +10

@morariu 

I'm going to flag this post for the Zapier Community Team. They should have more insight on this and can escalate to the support team if needed.

Sit tight, and someone will contact you soon.

Userlevel 7
Badge +14

Hi @morariu 

Might be best to open a ticket with Zapier Support on this issue: https://zapier.com/app/get-help