Best answer

Learndash Authentication 403 Error

  • 13 April 2020
  • 6 replies
  • 582 views

Userlevel 1

Hi @Danvers , 

 

I am having this same issue, I cannot connect Zapier to Learndash, and am getting this error response:

authentication failed: Got 403 calling POST https://www.mysite.com/, expected 2xx.

 

Was a resolution found yet, or can I be added to the list of affected?

Thanks!

icon

Best answer by steph.n 28 April 2020, 21:37

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +8

Hi @TBev ,

Thanks for reaching out! I have moved this post to a new thread as it sounds like you are experiencing a different error- sorry you are running into this.

If you haven’t already, I would start by making sure your Learndash permissions are squared away then try reconnecting the app. This article will guide you through how to do this!

Let us know if you are still encountering this error and we’ll dig deeper :slight_smile:

Userlevel 1

Hi @Liz_Roberts 

 

Thanks for your reply.

The only documentation I can find regarding LearnDash permissions is that I need to be an Admin user of my WordPress site, which I am. I have also tried creating a Zapier account with my boss’s email, the owner of the website and LD certificate, and get the same error.

I must be missing something? Is there another permission setting somewhere that I need to enable? I also emailed LD support and they did not indicate any other permissions that I needed to have.

 

Thank you so much for your help, I reeeeally want to use this Zap.

Userlevel 7
Badge +8

Hi @TBev ,

So sorry you are still encountering an error here!

One more thing to try: you may have to whitelist the Zapier IP - do you have such a setting available on your LearnDash account?

Give that a go and if it doesn’t do the trick, we’ll escalate this to Support to troubleshoot! I’ll be on the lookout for your response :relaxed:

Userlevel 1

Thanks for following up.

When I looked for the Zapier IP I saw that you do not use a static IP and there could be millions of IPs to whitelist so I am unsure how to do this.

There is not a setting in our Learndash account to do this but we use Sucuri for our website security and I can IP the Zapier address there. 

Thanks for your support!

Userlevel 7
Badge +8

@TBev thanks for taking a look!

I’m escalating this to our Support team- they will be able to dive into your specific Zap and troubleshoot from there.

Sit tight and they’ll be in touch just as soon as they can!

Userlevel 7
Badge +8

@TBev - Thanks for your patience! Lauren from Support got back to you with the solution, and I’m here to share it with our community should anyone seek to know what the answer was:

If you reach out to the Sucuri WebSite Firewall team via the link above they may be able to change the security settings to allow Zapier to access your site.