Best answer

I'm unable to publish my Zap draft

  • 25 April 2022
  • 47 replies
  • 4251 views

Userlevel 2

I am trying to update and re-publish an existing zap. I can't seem to get rid of the (has draft) notification on my Zap list. When I have been able to get to the place where the 'Publish' button is activated (it looks greyed out even when activated BTW) it says it will publish, then turn on the Zap ... but it doesn't. It says the modified Zap is published successfully but the (has draft) is still there, and the zap isn't turned on. What gives?

icon

Best answer by Danvers 18 May 2022, 18:23

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

47 replies

Userlevel 7
Badge +9

Hi there, friends. Thanks so much for reaching out! We definitely appreciate the feedback and ya’ll reporting this. 

Hey @MikeTak thanks for surfacing this! I am not sure why this is happening for you so I would recommend reaching out to our support team so they can dig in further: https://zapier.com/app/get-help

Keep us posted with the outcome! We’d love to inform others that may be experiencing this issue as well!

The reason we recommend filing tickets with support in this case is because it can be tricky to triage new issues in the Community without knowing the full scope. While we’re always happy to add users to existing bugs, surfacing new ones can be difficult and is best left to the experts in support who have the ability to check each individuals specific settings, logs, and isolate issues to a more granular level we simply do not have in Community.

Thanks in advance for your help in getting this sorted! In the meantime, here is a workaround that has been helpful for some folks:

  

This worked for me (for zaps that were already published/live, but that couldn’t publish new edits/drafts)

So, while you’re in the problematic zap (while you’re editing the draft and the “publish” button is grey and unresponsive): 

  1. First click “Save draft & Exit” button; 
  2. Then disable the zap (turn it off right there); 
  3. The re-enable the zap (turn it back on); 
  4. A popup should appear with options to publish your draft - select that option where you publish and enable your draft. 

This’s just saved the day for me! 

Jelena

 

Userlevel 1

This worked for me (for zaps that were already published/live, but that couldn’t publish new edits/drafts)

So, while you’re in the problematic zap (while you’re editing the draft and the “publish” button is grey and unresponsive): 

  1. First click “Save draft & Exit” button; 
  2. Then disable the zap (turn it off right there); 
  3. The re-enable the zap (turn it back on); 
  4. A popup should appear with options to publish your draft - select that option where you publish and enable your draft. 

This’s just saved the day for me! 

Jelena

Userlevel 1

I am having exactly the same problem. This began as soon as the new feature of ‘edit draft’ -- while the zap was still live -- came about for me so I think Zapier introduced a bug. It will not allow me to publish my zap despite that my edit was totally trivial (to a content field, not any of the process steps of the zap itself).

I’ve done some testing on this:

1/ Duplicate zap. Will not allow saving.

2/ Turn off (duplicate) zap prior to clicking edit. Will not allow saving.

3/ Delete ‘draft’ entirely. Start over: click edit. Will not allow saving.

Basically Zapier is somewhat broken right now: you cannot save edits to any zap. I will go file a formal ticket but this is just clogging up your customer service queue, it’s clear this is something QA and tech should be looking at ASAP given the number of complaints in such a short time -- and that it seems fully broken in this respect and being able to edit/change is a critical function.

Edit: I followed the staff link posted above to create a ticket. It made me login yet again (since I had to again for this help forum, that’s the third time), then when I did successfully, returned me to the same page that asked me to login yet again. I scrolled through the page and none of the options were creating a ticket. Whether this is because it’s not registering the login, or because it’s just trying to divert me into reading FAQs and so on, I’m not sure. So, in the end, I did not create a ticket.

Userlevel 1

I’m having the same issue. This is a terrible user experience, needs to be fixed ASAP. Duplicate to publish? Seriously? Version management would be great, but not dup to pub. I vote no on dup to pub!

Userlevel 2

I will set up a ticket if the behaviour persists … NOTE - I agree that the behaviour the prompted the original complaint has changed since I first posted. Things are working better now.

Userlevel 1

UPDATE, I tried turning off the zap, and then editing. Once I did this and click to save draft, I got a new message asking if I wanted to publish. 

If you cannot publish without disabling Zap, it seems Zapier should have a message explaining this, rather than make users search forums for an answer. Very disappointing to be wasting time on a problem that is easily avoidable with some on screen guidance.

Userlevel 7
Badge +9

Hey @MikeTak thanks for surfacing this! I am not sure why this is happening for you so I would recommend reaching out to our support team so they can dig in further: https://zapier.com/app/get-help

Keep us posted with the outcome! We’d love to inform others that may be experiencing this issue as well!

Userlevel 1

 

 

Thank you so much Jelena !

Userlevel 1

@MikeTak Was having the same problem, here’s what worked for me:

  1. Turn Zap OFF in main menu, before editing the Zap
  2. Go into Zap of interest, click “Edit”
  3. Wait for all information to load - Zapier is running REAL slow after this newest update
  4. “Save draft and exit”
  5. Use the button at the top of the individual Zap menu to turn back on, should have an option for “Publish draft and enable” (or something close to that, I forget the exact words)

And your Zap draft should be saved, and the Zap enabled! Hope this helps, I’ve been beating my head against a wall all weekend….

 

And to all the people who’s default answer is “just submit a ticket!” Thanks for not being helpful at all, but taking all the credit for solving problems! The point of a software community like this is to troubleshoot/problem-solve WITHOUT submitting a ticket or having to wait 48-72 hours to hear a response - if you don’t know, why are you even answering?!?!

Userlevel 1

I am also have the exact same issue as OP

Userlevel 1

Hey @MikeTak thanks for surfacing this! I am not sure why this is happening for you so I would recommend reaching out to our support team so they can dig in further: https://zapier.com/app/get-help

Keep us posted with the outcome! We’d love to inform others that may be experiencing this issue as well!

 

This seems to be a wider community issues, rather than each of us contacting support individually, could you let us know if :

A work-around that works for me is to duplicate the zap. You can then make edits in the duplicated zap and it lets you publish them.

 

^^  ...this is the best solution?

 

Are we really expected to have multiple versions of the same Zap, each with its own little update?

 

Can you please let us know how to re publish existing Zaps, that have been edited/updated. 

I am trying to update and re-publish an existing zap. I can't seem to get rid of the (has draft) notification on my Zap list. When I have been able to get to the place where the 'Publish' button is activated (it looks greyed out even when activated BTW) it says it will publish, then turn on the Zap ... but it doesn't. It says the modified Zap is published successfully but the (has draft) is still there, and the zap isn't turned on. What gives?

THE MOST ANNOYING FEATURE!!!!!!!!!!

This is just an absolute farce… for Zapier to have a know issue like this and just let it roll on for days without resolving the issue (while they send the support team off an a jolly) is just unbelievable!

If there’s a known issue they can’t fix within a small timeframe they should roll the version back, not leave people stranded and wasting their time!! 

I’m quite new to Zapier and have wasted most of the day thinking I’m doing loads of stuff wrong, when the reality that it’s not saving any of my edits and none of the workarounds are working for me either!  Highly unprofessional for a company of this size… I only started using this because the application that I’ve wasted most of today trying to complete thought it would be a good idea to do a Zapier integration before a standard open API.  

Same exact issue. All I did was re-name a Zap, and then it stopped working. This is a very big problem, and I’m beginning to get customer complaints because of the issue. Zapier needs to do something about this ASAP. FYI, I filed a ticket, and just got a message that the team is “on a retreat.” 

Userlevel 1

I am also having this problem. I cannot publish my edited draft. PLEASE HELP!!

Userlevel 7
Badge +12

Hi everyone! I’m really sorry for all the frustration surrounding the drafts feature not working the way that we’d expect. The issues that we are seeing are not one bug but a number of smaller ones that will affect some users in particular circumstances. 

We now have an article about this issue where I’ve gathered the different workarounds that have been suggested. If you are having any issues with the Drafts feature, please take a look at the article and contact the Support Team using the Get Help form

 

@jrspies I’d check that it actually has saved the Zap… initially I thought the work-around had done it for me but it hasn’t saved everything and even though the Test worked, you still get a pop-up message saying ‘Zap incomplete’ when I run it as published (no flag warnings prior to publishing) and different failure points when I run duplication of the same Zap.

Userlevel 1

Même problème pour moi aujourd’hui, depuis la nouvelle version de Zapier. Mes zaps me permettent d’automatiser des paiements et factures.

 

Plus rien ne fonctionne, mes 4 zaps restent toujours grisé et en mode brouillon. C’est la panique pour moi !

 

Personne n’a la solution SVP ?

 

C’est le week-end et je n’aurai pas de réponse du suport technique de zapier avant 3 jours au moins, je ne reçois plus mes paiements, je perds de l’argent.

 

Merci de votre précieuse aide !

Vanessa

 

--

 

Same problem for me today, since the new version of Zapier. My zaps allow me to automate payments and invoices.

Nothing works anymore, my 4 zaps are still grayed out and in draft mode. It's panic for me!

Does anyone have the solution please?

It's the weekend and I won't get an answer from Zapier's technical support for at least 3 days, I no longer receive my payments, I'm losing money.

Thank you for your precious help!

vanessa

same, this is ridiculous.

Same thing here, duplicated a ZAP made some changes. Can not publish changes, the button is greyed out I did submit a ticket, this is crazy. Never had any issues, fix this.

Same issue.

Hello, 

I have the same issue and cant publish a draft - the Zap has worded for ages but suddenly stoped working - so thought I would update this but now its changed and it wants me to publish the draft but its greyed out? 

Same issue. I created a ticket and find that support isn’t even available weekends. I’m running a business that doesn’t wait until Monday.

Ah… So it’s not just me! I can manually trigger each step, but obviously this is not ideal! I have logged a support request. Hope the devs can resolve this soon.

Userlevel 1

I’m also having this issue. The Publish button is always greyed out and my edits aren’t being saved