Question

How to set my account timezone back to UTC

  • 20 December 2022
  • 3 replies
  • 37 views

Hello,

Since this morning I've noticed something weird happening to dates fields on my automations. I have several integrations from pipefy to google sheets that uses dates fields. It was working as expected until last afternoon, but today the dates begun to change, and I found out that this happened because I've setted my account timezone to GMT -3.

Before I've changed the timezone, the integration was ok, but when I changed it to GMT -3 (wich is my timezone and the same I use on pipefy) some dates are coming out wrong on the sheets document. They are coming 3 hours less than they should. So, the fields from pipefy that doesn't have Time with the date, are coming to sheets with one day less.

Looking the history of the Zap, I found out that the fields that come from pipefy with date and time set, comes with the correct time zone (GMT -3), but the fields that comes from pipefy without time, Zapier set it to 00:00 and to GMT+0, than when it goes to the google sheets, Zapier reset it to GMT -3 and the result of the date is one day less at 9:00PM. In only happens with date fields that doesn't have time on pipefy.

Before I've change my timezone account, it was working as expected, but since I've changed I can't find a way to change my account back to UTC. I've tried setting my account to GMT+0, but it doesn't work either, since it will convert the dates fileds that comes with time from pipefy.

How can I set my account back to UTC?


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +9

Hey @ljunior! It looks as though you also wrote into support about this. So that we’re not troubleshooting in both places, I’m going to advise handling things with that team. Please do keep us posted with what the issue ended up being! We’d love to share your tips/solution with other members who might be running into something similar. Especially with timezones (we know they can be quite trickly!)

I've decided to post here, exactly because I've tried to find a similar topic but didn't find anything. 

Userlevel 5
Badge +7

Hi there @ljunior - looks like Support gave you a few ideas, I’ll post them here in case anyone else runs into a similar issue in the future 😀

 

In order to reset your time zone, you can change that here -https://zapier.com/app/settings/9488181/profile
 
You also may want to remove the timezone from your Zap under the 'Settings' menu. 

Lastly, If that doesn't fix the issue, it may be worth checking the timezone used in the Google Sheet as well: 
 
https://support.google.com/docs/answer/58515?hl=en&co=GENIE.Platform%3DDesktop#zippy=

 

I hope those changes got you back on the right track with your Zap. 

 

Best,

Rachael