Best answer

How do I map JotForm form fields to Google Sheets via Zapier?

  • 6 August 2023
  • 3 replies
  • 121 views

Userlevel 1

I am experimenting with zapier and trying to do a simple integration where if someone fills out a form on jotform, it adds an entry into google sheets.

I hooked into jotforms and set a "trigger" to hook into one of my forms. However, the fields that are pulling in are things like "form_id" and "ip address". instead of fields on the actual form like "name" and "email_address". I am using the "New Submission" event.

 

icon

Best answer by sessionsafe 9 August 2023, 16:33

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 1

Ok, none of those solutions worked. However, I was able to find the solution by “reconnect my Jotform account in zapier”. So in zapier:

- Go to "My Apps".
- Click the app with the app connection you want to reconnect.
- In the Connections tab for that app, click the three dots icon Nav
- In the dropdown menu, click Reconnect.
 

The background articles I used to get these info is:
https://help.zapier.com/hc/en-us/articles/8496290788109#disconnect-your-app-connection-0-3

https://www.jotform.com/answers/5376531-zapier-other-fields-in-the-form-are-not-showing-up-on-the-zap

Userlevel 7
Badge +14

Hi @sessionsafe 

Good question.

 

JotForm values are missing or incorrect

 

There are several settings that can cause your JotForm values to appear incorrect or not appear at all. Please check the following settings:

Europe datacenter

If you see blank values or values like “N/A” and your JotForm account is not based in the United States, you may need to change your JotForm settings.

  • In JotForm, go to your data settings.
  • Clear the Europe Datacenter field.
  • In Zapier, go to My Apps.
  • Click Add connection.
  • Search for and select JotForm.
  • In the dialog box, select No for the Do you use European datacenters field.

HIPAA compliance

If your JotForm account has HIPAA compliance enabled, Zapier won’t receive values for any protected fields.

If you don’t need HIPAA-compliant forms, you can disable that feature:

  • In JotForm, go to your data settings.
  • Click Disable HIPAA Compliance
  • In Zapier, go to My Apps.
  • Click Add connection.
  • Search for and select JotForm.
  • In the dialog box, select No for the Account HIPAA compliant? field.

Form settings

If you see long alphanumeric strings instead of your form values, you’ll need to disable the Encrypt Form Data setting.

  • In your form, click Settings.
  • In the left sidebar, click Form settings.
  • In the Encrypt Form Data field, select No.
Userlevel 7
Badge +11

Great work here, @sessionsafe! 🙌

So pleased you were able to get the correct form fields pulled in by reconnecting your JotForm account. And thanks so much for circling back here to share your solution with the Community, it’s much appreciated! 🤗