Question

How do I configure a Zap to send both email and name data from Squarespace sign-ups to my Brevo email list?

  • 23 January 2024
  • 8 replies
  • 49 views

Hi there,  

I have a Zap that sends sign-ups on our website (Squarespace) to our email list (on Brevo), so that they automatically receive our newsletter. (I have this Zap in 3 versions, as there are 3 spots on my site where people can sign up.)

However, for each of these Zaps, only the email addresses of sign-ups on Squaresapce are making it into the Brevo email list, even though when people sign up they leave their first and last names. I can go into the back end of Squarespace and see that this data is being captured there. 

[I’ll attach 3 screenshots of what I think are the key parts - if you need more, please say).

Please can you tell me how to make the Zap send email addresses AND also first and last names? I tried something but it failed, so I'm completely stuck! I’m new to Zapier, so don’t assume any technical prowess ◡̈  

Thanks in advance!


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

8 replies

Userlevel 7
Badge +14

@Alex Ab 

Perhaps record and share a link to a Loom video?

I’m sorry @Troy Tessalone  - you’ve been so persevering too! I’m simply uploading .png files, and on my machine some show on Chrome, some on Firefox, and none on Safari. I’ve no idea what to do just to get these screenshots onto this page, let alone have my problem solved. This is so frustrating!

 

Userlevel 7
Badge +14

@Alex Ab 

I checked across multiple browsers. (Firefox and Safari)

 

@Troy Tessalone I’m sorry. This is crazy glitchy!

I’ve uploaded and retested and the ones below are opening properly. Apologies for the hassle & thanks for bearing with me!

Userlevel 7
Badge +14

@Alex Ab 

I can see the screenshots but I’m unable to open them to view them larger to see details.

I was on Chrome, so I opened this page in a different browser (Firefox) and you’re right, the original post doesn’t show the screenshots - even though in Chrome on my laptop it does!

Anyway, in Firefox I can see that my second attempt at uploading screenshots is showing. I hope that they can be seen there.

Hi @Troy Tessalone, thanks for getting back to me. This is so strange, as they show as uploaded on my screen! So puzzling. 

I’ll try to upload them again here.

 

Userlevel 7
Badge +14

Hi @Alex Ab 

The attachments did not upload.