Google Sheets not updating rows suddenly and constantly

I am using Zapier like this-

If one row is updated in Google sheet A

Then one row is created in Google Sheet B

The issue I am having is it worked fine yesterday when first turned on.  Then it stops working.

There might be 5-10 new entries in Sheet A a day and ZAPS are not even grabbing those anymore.

It’s frustrating and I do not know what is going on? It worked fine and now it’s not. I created the zaps like 5 different times and they all worked fine for a few hours then stop.  Anyone else having this issue?

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

13 replies

Userlevel 7
Badge +12

Hi @admartel, welcome to the Community!

Google Sheets can be super fussy, so if things aren’t formatted quite right or if there has been a structural change on the sheet while the Zap is switched on that can cause some trouble.

The following changes to a sheet while a Zap is switched on can cause a disconnect with your Zap:

- Deleting existing rows or columns.
- Adding rows anywhere other than to the bottom of your sheet.
- Resorting the sheet.
- Renaming/adding/rearranging new columns

If you need to make any of those types of changes to your Google Sheet, you will need to turn your Zap off while you make the change, and then turn it back on again after.

Another thing that can cause trouble on your sheet is any blank rows. You will need to make sure your sheet has no blank rows in the middle, only after your last row of content.

To test this out, please can you try the following for me:

1. Turn your Zap off from the Dashboard.
2. Carefully check your Sheet for any blank rows and delete them.
3. Turn your Zap back on.
4. Test by adding a brand new row to the bottom of the sheet.

Even if you don’t have any blank rows, please be sure to turn the Zap off and on again from the dashboard as this will give things a reset if any structural changes were made.

Can you give that a try for me and let me know how it goes?

I tried turning off and turning on and it didn’t work.  If I run a test it works fine and adds a row for the test. It just doesn’t seem to want to fire when triggered.

Do we know how often a Zap fires? Is it every time it is triggered or does it take a while?


Actually when I do a test it grabs the new rows and adds them to google sheet B with no issue. But it won’t trigger on it’s own unless I manually test. 

Userlevel 7
Badge +8

Actually when I do a test it grabs the new rows and adds them to google sheet B with no issue. But it won’t trigger on it’s own unless I manually test. 


Hi @admartel, zaps will only grab new rows / new data only. Our zaps fire off in 15-min intervals or instantly as the zap would outline. Have you given it about 15-20 minutes to fire off when it’s left as is and there’s new rows? Please let me know if it’s still not firing off for you after that time frame and we’ll work together on resolving this with you!

still not firing but in the middle of the night they all zapped over to the sheet B.  I think it’s weird there is such a delay. I stopped working at 6pm and at some point before morning everything showed up?


Userlevel 4
Badge +2

Google Sheets is so darn fussy that I use it as little as possible. I’ve been building a combination of Zaps that lookup rows and update them. Works sometimes, and other times I get errors. So, my solution is… grab everything I need from Google Sheets and shove it in Airtable. Keep on trucking.

I know that’s not a viable solution for everyone but for me, every time I find myself hitting my head against a Google Sheets wall, I turn to Airtable and life gets better immediately.

Userlevel 7
Badge +12

still not firing but in the middle of the night they all zapped over to the sheet B. 


That definitely isn’t the kind of thing that we’d expect to see with a Google Sheets triggers. If you look at the task history for the Zap, what time does it say that the tasks happened?  

Yesterday worked fine and every time the trigger was set on sheet A things were copied to sheet B.  Today it only has fired once even though things are coming into sheet A. 

Here are the times for yesterday:

3-18-2020   20:18

3-18-2020  15:48

3-18-2020 13:42

3-18-2020  10:43

3-18-2020 06:31


So far today it has fired only once even though 3 things came in:

3-19-2020  10:34:53


Userlevel 7
Badge +12

Hmm, we I think that we’re getting closer to a solution. 


Your trigger is an Updated Row, is that correct? When you are updating the row, are you adding brand new information to the row, or are you putting information in the row that might have been there before? For example, something like a column that says Yes/No and you might have yes in it, then change it to no, and then back to yes?


Google Sheets Updated Row will only trigger if the information in the row is brand new. If the information in the row is the same as has previously been there, it wont trigger the Zap. Do you think that might be what’s happening here?

New information is being entered in the row.

This was a clean sheet to begin with.  Information is added to the row and all columns are full.

So far today it fired once for one row and not for another row that was added.

I’ve been having the same issue as recently as today too.

Please advise...

I actually turned the ZAP off.  It was just not working the way we need it to and we are short on time.

My other Zap that is sending gmail attachments to a Google Drive folder is working fine which is great.


Userlevel 7
Badge +12

Hi @admartel - I’m really sorry for the delay in coming back to you on this!


The sheet that should trigger the Zap - what kind of data is in the sheet? Specifically, are you using any queries to pull the data from somewhere else, or formula in the sheet? If so, that could be what was causing the trouble. When you use a query formula, then the sheet that triggers the Zap will only update when that sheet is opened, which can cause an issue with sporadic updates, similar to what you were seeing. Could that be it?