Best answer

Find List on Board in Trello step “invalid value for value” error

  • 3 November 2021
  • 2 replies



I am trying to create a zap where depending on a criteria (based on a google form submission), a new trello cards gets added to a different list (same board). However, the ‘create card in trello’ zap does not seem to take any custom value when selecting the list. When I just select the correct list from the dropdown menu, everything works fine. However, when I pull in the list ID (long numeric value) from a lookup in a previous step OR after going through a ‘Find list on Board in trello’ search step, the zap doesn’t continue.  The error message is: The app returned “invalid value for value”.


I’ve tried the same with using the list names (rather than the IDs) with the same result. Any help is much appreciated!




Best answer by Liesbet8 3 November 2021, 16:05

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +14

Hi @Liesbet8 

Please post screenshots with how your Zap steps are configure that are having an issue, thanks.


A workaround might be use to separate Zaps with Filters, or a Zap with Paths.



Hi Troy, 


Thanks for reaching out. The helpdesk have since helped me with this. Apparently, the issue I had was with the label formatting not with the list ID.