Best answer

Dropbox or Google Drive to Ghost Post Drafts are empty

  • 22 May 2022
  • 4 replies

Userlevel 1

So I’ve tried the following two scenarios and neither seem to add proper file content (HTML or Mobiledoc body) to a Ghost CMS/blog’s draft post

  1. Dropbox file upload to create draft post in Ghost
  2. Google Drive file upload to create draft post in Ghost

Has anyone been successfully able to setup a Ghost integration/zap such that the post body actually fills out?


Best answer by farezv 31 May 2022, 10:17

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +14

Hi @farezv 

Good question.

GDrive won’t return the file contents.

Dropbox will return the file contents.


Userlevel 1

@Troy Tessalone Thank you for clarifying the difference between the Google Drive and Dropbox sync. These are simple plain text files with .txt extension so not huge in size. This particular one in the image below is 7 kb, far less than the 100 MB threshold and the `Include file contents` is set to “Yes”.

I’ve tried File Text option as shown below but it says “Binary contents unsupported” and the blog post is empty.

The tag and author information propagates correctly.

Here’s what the Ghost draft post looks like. 


Okay so the above file was generated using a Google Cloud API while the test file below was manually created in my Dropbox folder. 

While I still need to diagnose the actual issue, I’m leaving this reply here so other Zapier members can find the thread in search results. This is most likely some sort of END of file or file formatting issue. On the surface both are text files but I bet the Google API generated one is encoded in a way that’s causing my “Binary contents unsupported” issue.


Userlevel 7
Badge +12

Hi @farezv

Thanks for letting us know that you uncovered that a manually created dropbox file worked while the one created with the Google API doesn’t - some good detective work there!

Userlevel 1

Of course @Danvers, just trying to narrow down the issue. So it turns out this was a bug on my end; my Python script that calls Google Translate’s API to generate this file didn’t have a file.close() call in it causing the file to be created with a strange format. Which is what caused the “Binary contents unsupported” error.


Zapier’s Dropbox to Ghost integration is seamless and works as expected for post drafts!