Best answer

Cannot read property 'workflow_id' of undefined

  • 28 September 2020
  • 18 replies
  • 875 views

Userlevel 2
Badge

Hi, 

I am getting a brand new error message on old Zaps. Cannot read property 'workflow_id' of undefined

Strange thing is, I have not made any updates. Also, every step of the Zap has a green checkmark, and when I get the error… it doesn’t even tell me the section to investigate. Now I am unable to run the few zaps that are showing the error. One correlation - I am running a Python script in them… but I haven’t changed anything with the code. The API I am calling has had a recent update, but they are telling me that it isn’t anything they introduced. 

 

Thanks 

Tom

icon

Best answer by Zoho Subscriptions 5 October 2020, 09:33

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

18 replies

Userlevel 7
Badge +11

Hi @SandyAujla!

I see that you’ve written to our Support team and they have responded with some directions and also some questions. Please continue the conversation there, since they’re able to dig into your Zaps and our detailed logs :)

And @Tj Bakare it looks like you also wrote to our Support team and they identified the error message we’re seeing, and that your next step will be to reach out to Zoho about it.

 

I am having this same issue. it keeps saying error with Property workflow_id. All the tests are successful. As a result, my ZAPS cannot be turned on. I'm creating simple invoices using Paystack after trigger. 

er from Zoho books. 

I am having this issue only with Zoho Books @Zoho Subscriptions 

I am having this same issue. it keeps saying error with Property workflow_id. All the tests are successful. As a result, my ZAPS cannot be turned on. I'm creating simple invoices using Paystack after trigger. 

er from Zoho books. 

I am facing the same issue. Can anyone help me with this? Earlier it was working fine but suddenly start showing this error.

Userlevel 7
Badge +12

Hi @Zoho Subscriptions, thanks for stepping in with an update on this :slight_smile:

@all,  Regret the inconvenience caused. Hereafter, you’ll see the actual error due to which the workflow was unable to be created at Zoho Subscriptions.

Userlevel 2
Badge

@tommyhen and @hub No real progress. I will say that I spoke with Zoho support this AM and the person on the phone believed it was an issue with a limit in the number of integration connections we are allotted with our subscription with Zoho. He could not tell me anything more and instructed me to send an email to support with screenshots. Zoho Support is not great and it takes a while no matter how urgent.

Are you both seeing the error with Zoho integrations only? That’s my situation. I am hoping that they magically reset with Oct coming tomorrow. Please let me know what you have discovered. 

@Digital Hi, i’m having these issues as well. It was working earlier on in the day and even replicating the process it hasnt worked. 

@Digital i’m having the same issue.  Any updates?

Userlevel 2
Badge

@Danvers Thank you for the follow-up. I have attempted to open two tickets for support and have yet to hear back. Thanks again. 

 

Userlevel 7
Badge +12

Hi @Digital, I can’t see any known issues that line up with the error you’re seeing so I think it’s best for the Support Team to take a look at this with you. I’ve passed your post on to them and someone will be in touch via email as soon as possible. 

Userlevel 2
Badge

Community… I have created a brand new ZAP and all I am doing is emailing… and I still get the same error. 

Userlevel 2
Badge

@Troy Tessalone I have done both of those things. I am dead in the water. I am hoping Zapier can jump in and help.

Userlevel 7
Badge +14

Did you try testing each Step of the Zap again?
Otherwise, try making a COPY of the Zap.

Userlevel 2
Badge

@Troy Tessalone The problem doesn’t occur when creating the ZAP. As I mentioned.. each step of the ZAP works and has a green checkmark. It only fails when turning on the ZAP at the very end. 

Userlevel 7
Badge +14

When configuring the Zap, test each Step and in doing so you should be able to isolate the Step that is resulting in the error and troubleshoot a fix from there.

Userlevel 2
Badge

@Troy Tessalone Unfortunately, the task history doesn’t work for this issue. I made an update to the password I pass in a script. When I made that change, the Zap would never turn back on. 

Errors in my Zap

  • There was a problem activating your Zap.

    Cannot read property 'workflow_id' of undefined

Userlevel 7
Badge +14

Check the Zapier Task History here: https://zapier.com/app/history/

You can dive into the Details of a triggered Zap that resulted in an error to see the DATA IN and DATA OUT of each Step, which will indicate at what step the Zap returned an error, then troubleshoot from there.