Best answer

Automated Email Reminders to Send Links for Online Classes

  • 9 June 2020
  • 6 replies

  • Anonymous
  • 0 replies

Hello everyone,

I’ve been brainstorming how to build up an efficient workflow for my company’s email notification system and struggling.

We are currently running online workshops where kids meet in private groups to play Dungeons & Dragons. The groups meet 1-2x a week. An hour before every group starts, I have Zapier send an email with everyone’s character sheets (as a Google Doc link), a chatroom for rolling dice, and a Zoom room.

I’ve been able to automate most of this process so Zapier can read the time, date, and Zoom location to paste into the email. Now though, I want to find a way to more efficiently link in each kid’s character sheet so I don’t have to paste every single kid’s name and every single character sheet by hand.

My initial instinct was to set up a Google Sheet with names in one column and links in the other. However, the only action that can read this information is “Get Many Spreadsheet Rows.” This action takes all the information from the spreadsheet and puts it into a single JSON array.

Now, I’m not sure how to take this information and paste it neatly into an email. Right now, it sends out like this:

Character Sheets:
Ellen,Ayoel Ironbloom,Ranger
“The Kitten”,Fighter,Whit,Ponder Willow,Warlock

Links are pasting together, there are no paragraph breaks, and there are no spaces between the commas. I’ve tried to format this information with Formatter by Zapier, but since the Google Sheet output is a single text array, most of the formatting functions don't work.

Does anyone know how I can format this text, or can anyone offer a better method of accomplishing the same goal of sending links and information from a single source?


EDIT: This post was edited by a moderator to remove personal information from the images. Please be careful not to share private information as this is a public Community


Best answer by nicksimard 16 July 2020, 03:17

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +11

Hi @NYSocietyofPlay!

I used your challenge as inspiration for today’s Workflow Wednesday piece. You can check out here to see if it solves your problem. If you have any questions you can reply here :)

Userlevel 7
Badge +12

Hi @NYSocietyofPlay! First of all, I love D&D so I’m always happy to help folks use Zapier to play 🙂


As you’ve figured out, the Get Many Spreadsheet Rows action will return the different rows as line items, but in general email systems can’t handle line items, so they just display the text is a comma separate list (which is what you can see above).


The good news is that you can use the Formatter to turn line items into a text field, which is easier to work with.  To do that, add a Formatter action and choose Utilities > Line item to text. By default, the step will separate each part of the field with a comma, but you can also choose to separate each part of the field with a space or new line by entering :space: or :newline: in the separator field


I think that will get you most of the way to what you need, if it doesn’t quite get the format that you want, could you share how the fields look in the Zap and exactly how you want the email to look, so that we have a better idea of what we’re working with. Don’t forget to remove any personal/private info from the screenshot if you do share one!

Userlevel 7
Badge +12

Thanks for sharing the output of the step that you tried @NYSocietyofPlay


Can I double-check which Formatter function you were using for that? Was it line-item to text or text to line-item? Also, if you can share the output of the Get many rows step as a screenshot that would be super helpful, it’ll give me a clue as to how the information is coming into the Formatter step. Thanks!

Hello Danvers,

I was using the Line Item to Text.

Here’s the output for the Get Many Rows step:

Here’s what happens when I put it through the formatter:

Can you decipehr what’s happening here? It seems like the formatter isn’t able to split apart the input, so it duplicates the full input based on the number of line items.

Hello Nick,


Thank you for your response! I’m flattered to see this question appear on Workflow Wednesday. I hope the information can help other Zapier users.


Funny enough, I was brainstorming a similar solution myself where I used “Find Many Rows” instead of “Get Many Rows.” Instead of searching by date, I set up the search by the


field, which contains the title for each group (ex. Group A - Green Dragons). I would have done that earlier, but I didn’t understand what “Lookup Value” meant when I was first reading the FAQ.


The last question I have: Is there a list of general text separators on Zapier like





I’ve tried to find a list of these kinds of formatting codes like these but I haven’t been successful. 

Hello Danver,

Thanks for sharing those formatting codes. I was trying to find a list of the codes on the Zapier help docs, but couldn’t figure out where they were.


Unfortunately, the line command doesn’t seem to be working the way I want to. I actually like the way that the list is exported in the Get Many Spreadsheet Rows like this




0 Ellen

1 Ayoel Ironbloom

2 Ranger


0 Simo

1 Cato Windriver

2 Bard


0 Anna

1 Kenny the Kitten

2 Fighter


0 Whit

1 Ponder Willow

2 Warlock


Unfortunately, when I use the :new line: separator, this is the result:



Ellen,Ayoel Ironbloom,Ranger,Simo,Cato Windriver,Bard,Anna,Kenny the Kitten,Fighter,Whit,Ponder Willow,Warlock


Ellen,Ayoel Ironbloom,Ranger,Simo,Cato Windriver,Bard,Anna,Kenny the Kitten,Fighter,Whit,Ponder Willow,Warlock


Ellen,Ayoel Ironbloom,Ranger,Simo,Cato Windriver,Bard,Anna,Kenny the Kitten,Fighter,Whit,Ponder Willow,Warlock


Ellen,Ayoel Ironbloom,Ranger,Simo,Cato Windriver,Bard,Anna,Kenny the Kitten,Fighter,Whit,Ponder Willow,Warlock


Ellen,Ayoel Ironbloom,Ranger,Simo,Cato Windriver,Bard,Anna,Kenny the Kitten,Fighter,Whit,Ponder Willow,Warlock


What’s the issue happening here?