Best answer

Adalo&MYSQL zapier not working (Adalo record Update)

  • 6 August 2020
  • 6 replies
  • 166 views

Hi,

 

Im trying to connect a MYSQL database and update an Adalo table record when a MYSQL table record is updated.

i create the zap but in the second step, Adalo part, the configurations asks for a “Record ID” not defined in the Adalo back end.  The field is mandatory:

 

If you enter the Adalo’s table ID, the test respond with an error:

Is it not possible to use this integration?

Regards,

Antonio

icon

Best answer by DigtalPyme 6 October 2020, 20:03

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +9

Yes - In that case, if it’s just an error, it would be the zap publisher - I would recommend sending a note to Adalo and asking them if they can fix

Userlevel 7
Badge +10

Hi @DigtalPyme 

Were you able to get this resolved with Adalo?

Hi Andrew,

Yes, the issue was solved.  The Adalo zap was expecting an internal record ID and not the ID record as I was using.  Once used the right field, the zaps is working properly.

Antonio. 

Userlevel 7
Badge +9

It will be, but what this is saying is that you need to know the Adalo record ID, which isn’t available to you outside of the “new record” trigger. This means that you will need to send that ID to MySQL so that the two can speak to each other. 

 

Once you set up that automation, this automation will be possible. 

Thanks andywingrave  for your answer.  The zap situation I am planning is not sending Adalo info to MySQL but the other way around.  I am sending the Adalo ID from MySQL to Adalo, but Adalo set up configuration for the zap is asking for a Record ID that IS NOT the Adalo ID.  When I set the Adalo ID in this field is when I get the error message.  If I enter  a number, lets say “1”, the zap updates the first record of the table.  According to the info below the field “is not available trough the Adalo iterface” suggests that Adalo is not ready for the update trigger.  I have checked the “create” trigger and it works.   In case of a zap is not working between to applications, who is in charge of fix it?.  In this case my guess is Adalo since their part is the one not working.  

Thanks, Case opened in Adalo’s support.