Zap makes time 1 hour earlier

  • 27 February 2021
  • 5 replies

Userlevel 1

Hi i having trouble with time.

I have set my timezone in my profile correctly (UTC+1, “Europe/Amsterdam”).
I have set my timezone in Slack and also in outlook on (UTC+1)

I made a Zap with outlook calendar > when new event is made, de zap pushed the event to a slack channel. But with the wrong time. 

So someone makes an event in outlook between 14:00 and 15:00
In the test it's coming into ZAP at 13:00 tot 14:00. and it pushes that time into a message to slack. i tried other accounts. Even a google calendar wouldn't help.

Whatever i do, nothing helps to get the time right.

Hope some one can help me out.

This topic has been closed for comments

5 replies

Userlevel 7
Badge +10

Hi @B105 

Check your Zap Runs history to see the DATA IN/OUT for each Zap step:

You can use a Formatter step to adjust the Time Zones if needed:

Userlevel 1

Hi Tnx Troy Tessalone for your quick response.

Also in data in and out the wrong time is given.

I love to use the formatter. But the fact is, i use the free version know. And can only add 2 steps in total. So two formatter steps would be 4 in total. :(


Userlevel 7
Badge +10


Your options are to somehow fix the originating app time value being provided to the Zap trigger OR upgrade your Zapier plan to use the Formatter.

Userlevel 1

Tnx Troy for you tips. I can't change anything in outlook .And a plan for 20$ for one notification is a little to much. I think Zapier isn't the right app for us :(.

Thanks for your time,
Good Night

Userlevel 7
Badge +10


If you do pay for Zapier, figure out how to leverage it to automate other workflows to get the most value out of your paid plan.

Check out all the available app integrations here: