Question

Quickbooks Customer Email Not Working

  • 13 October 2021
  • 3 replies
  • 13 views

I’ve created a new zap that automatically creates a new invoice when a trello card is moved to a new list however…. when left blank, the email field should be picking up the default email for the customer however it’s not working and as a result the email isn’t being sent? I’ve checked everything twice and can’t see what i’m doing wrong. 

 

The invoice is being created and everything else is working great, it’s just not assigning an email to the invoice and as such isn’t being sent...

 


3 replies

Userlevel 7
Badge +11

Hi @Tom Crane 

The Trello field needs to be mapped to the Email field for QBO.

Check out this help article for how to map variables between Zap steps using the ‘CUSTOM’ mapping option: https://zapier.com/help/create/basics/set-up-your-zap-action#set-up-your-action

Hey Troy, thanks for your reply. I’m not sure what you mean? I don’t have a email associated with the Trello card so there is no email to pull in here. I want it to use the QBO Customer email as this suggests it will (but it doesn’t)  Have attached a screenshot of the whole section so you can see what I mean.

 

I have it doing exactly what I want It just isn’t assigning an email to the invoice and as such isn’t being sent.

Userlevel 7
Badge +11

@Tom Crane 

Couple notes:

For the Customer field, looks like you have 1 Customer selected, that means all the Invoices will be created for the same Customer.

Is that what you want the Zap to do?

If yes, then check that the selected Customer has a Primary Email address set in QBO.

 

Reply