Best answer

Problem Passing Date to Google Calendar

  • 1 April 2020
  • 4 replies
  • 255 views

I am using a Zap that creates a Google Calendar appointment from data originating in a Formsite form.  Formsite has a date control, but no time control.  I have created a time control using a list box.  The date control outputs the date as “04/01/2020”.  The time control outputs the time as “4:00pm”.  I have another field that concatenates both controls to create a field with date in the format “04/01/20204:00pm”.   The Zap works fine, when creating a detailed Google calendar appointment, except that Zapier creates a Calendar date with the wrong date and time. I have tried passing the fields singly and together.  I have tried to use the Zapier Formatter application to convert the dates.  Nothing seems to work.  Can anyone Guide me step by step through getting the date and time in the proper format so that the correct date and time shows up on the Google calendar?  

icon

Best answer by jesse 10 June 2020, 23:02

@regreenspan just wanted to follow up on this thread and close the loop! I’m glad you were able to get the formatting sorted out. Sometimes the hangups with formatting conversion happen with the “From Format” filed. You’ll want to make sure you are defining the format using these variables instead of mapping a field there: https://zapier.com/help/create/format/modify-date-formats-in-zaps#customize-date-time-options

If that doesn’t work, you might check the timezones of your calendar, the app you’re connected to, and the timezone within the settings of your Zapier account to make sure they match. If they do, then we’d suggest Andrew’s fix of using the “Add/Subtrack Time” Formatter utility to correct for any difference.

View original

This topic has been closed for comments

4 replies

Userlevel 7
Badge +10

Hi @regreenspan 

GCal can be a little fragile with accepting date/time inputs. Can you show us a screenshot of exactly how you have those mapped?

I was finally successful in creating the Start and End dates and times for the Google Event.   However, when I run the Zap, the event is scheduled one hour later.  I used two transformers, one to convert the date into a date format.  The second adds 15 minutes to the original date.  These dates are used to schedule a 15 minute appointment.  I think the time zones are set correctly.  Perhaps the format I am using for the conversion is not compatible with Google calendar.  Attached are screenshots.  Thanks for the help.  

Userlevel 7
Badge +10

@regreenspan - If you’re sure timezones are correct, one quick a dirty fix is to use the “Add/Subtrack Time” formatter step to correct for any difference.

Userlevel 7
Badge +8

@regreenspan just wanted to follow up on this thread and close the loop! I’m glad you were able to get the formatting sorted out. Sometimes the hangups with formatting conversion happen with the “From Format” filed. You’ll want to make sure you are defining the format using these variables instead of mapping a field there: https://zapier.com/help/create/format/modify-date-formats-in-zaps#customize-date-time-options

If that doesn’t work, you might check the timezones of your calendar, the app you’re connected to, and the timezone within the settings of your Zapier account to make sure they match. If they do, then we’d suggest Andrew’s fix of using the “Add/Subtrack Time” Formatter utility to correct for any difference.