Possible issue using two variables in a filter.


Userlevel 4
Badge +4
  • Certified Zapier Expert
  • 83 replies

Need to use two variables in your Zapier Filter steps? We've got a hack for you!

If you're a regular user of the Zapier Filter step, you'll probably have got frustrated by the fact that you can only compare a variable value to a fixed value.

But, what if we told you there was a clever way to make it possible?

 

Does this work 100%? It seems like it didn’t work for one of my Zaps. It ended up going in a loop and used up all my tasks (20k) in one day. 

 

See screenshot: https://share.getcloudapp.com/2NuXOz6G

 

@AndrewJDavison_Luhhu 


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +10

I’ve never had problems with it @Nate, but yeh something isn’t right there!

Let me flag it for a Zapier staffer to look at!

Userlevel 7
Badge +11

Hi @Nate! I’ve moved your comment to the Ask the Community section to make sure that we can take care of it for you :slight_smile:

 

I’ve not seen this workaround have this problem before, so I’m going to escalate it to the Support Team so that they can take a closer look at the Zap. I’ll be in touch via email shortly to ask for a few more details before we hand this over to the Support Team. 

Userlevel 4
Badge +4

Thank you @AndrewJDavison_Luhhu and @Danvers

Userlevel 7
Badge +11

Hi @nate! I can see that you got some help from our Support Team and I was wondering if you were able to get to the bottom of why the filter didn’t work as intended? Thanks!