Question

Bug? Match All option not working for Extract Pattern Step.

  • 22 September 2021
  • 5 replies
  • 38 views

 I’m trying to set up a Zap that notifies our team members in Slack when they’ve been @mentioned in Intercom. I’ve got it working for single @ mentions left in a note, but can’t get it working if someone @ mentions multiple people in the same note.

The more I look into it, the more it seems like something is broken in Zapier. While testing, I can see that Zapier uses re.findall() when you select the Match All property for Extract Pattern steps, so I flipped this on to account for multiple arguments.


When I test this regex search in VSCode, the code works as expected. But in Zapier, it only returns the first value as if Zapier is still using re.search() instead of re.findall() behind the scenes. Am I missing something here or is this a bug? If so, how do I get this looked at? I can’t figure out how to reach the support team.​​​​​​

 


5 replies

Userlevel 7
Badge +11

Hi @atiner 

What app are you using in the Zap to do the regex? (Code or Formatter)

https://zapier.com/help/create/format/find-text-with-regular-expressions-in-zaps

 

May be best to open a ticket with Zapier Support regarding this: https://zapier.com/app/get-help

Yup, that’s the set up. Reached out to the support team but I’m not sure where to see if they write me back. Will keep an eye out! Strangely, when I went to check on the zap the right outputs magically appeared. However, as soon as I hit Test the same issue occurred where only one output showed up. 

 

Userlevel 6
Badge +8

Hey @atiner, welcome to the Community!

It looks like our Support team has responded to your email with some suggestions. :) 

If you can’t see their email, please check your spam/junk folder in case it’s ended up in there by mistake. And if you still can’t find it, try searching your whole email inbox for emails ending in ‘@zapier.com’. Hope that helps!

Userlevel 7
Badge +11

@atiner 

Make sure to check the example data you’re manually testing with VS when the Zap is ON and run.

You can change the trigger test data: https://zapier.com/help/create/basics/change-the-test-data-in-your-zap-trigger

You can check your Zap Runs history details for the DATA IN/OUT for each Zap step: https://zapier.com/app/history/

Just found the email from support. It looks like there were newlines being added to the inputs that I wasn’t aware of. Turning on the dotall option finally got all of the args to come out correctly. Not sure where the new lines came from. They used regex101.com to catch that issue.

 

Reply