Best answer

Append Text to Document in Google Docs changes template Header


Userlevel 1

I set up the “Append Text to Document in Google Docs” feature from a new line in a google sheet form results doc and it was working great but now… it’s changing the Header of the Google Doc. 

Logo and company info is clearly within the Header area and NOT in the document itself
Header before the “Append Text to Document in Google Docs” is added.

After I run a test even with my cursor at the bottom of the Google Doc the results still reformat the Header by aligning the logo on the right hand side. 

What changed? 

How can I append a google doc without it reformatting the header? 

icon

Best answer by Troy Tessalone 7 May 2021, 16:36

Hi @Recovery 

Perhaps instead try this GDocs action: Create Doc from Template

 

Here’s an article about it: https://zapier.com/blog/create-autopopulate-google-docs-template/

View original

5 replies

Userlevel 7
Badge +10

Hi @Recovery 

Perhaps instead try this GDocs action: Create Doc from Template

 

Here’s an article about it: https://zapier.com/blog/create-autopopulate-google-docs-template/

Userlevel 1

Hey Troy, The problem is with the Template option the document only updates the first use of the {{First Name}} and other references. It’s not ideal and doesn’t solve the problem at hand. 

For instance why when I first set up this Zap did the header stay as it was? 

The only difference I can think of is that the doc had a blank “Date” typed at the top of the document. I did remove that because I automated it but perhaps that bit of text was preventing the header from being re-formatted… will test that theory now. 

Userlevel 1

So both tests were a failure - starting to think paying for the full service Zapier was a mistake… the basic functionality of these Zaps are useless;

 

Here  is what happens to the Template option when using my data input it only places the text from the Google sheet once and then leaves the rest of the document like: {{First Name}} {{Last Name}} etc. 

I also tested the idea I posted above about entering some text at the top of the document in hopes that header would not be re-formatted but no luck:

 

I was hoping Zapier could help automate my Dad’s business letter writing but at this point it’s making things worse - maybe I should apply for a refund… *sad*

Userlevel 7
Badge +10

@Recovery 

For the GDoc Template to work as expected there are some tricks.

For the placeholder values remove all spaces between the double brackets.

For example, {{FirstName}} instead of {{First Name}}.

Also, all instances of {{FirstName}} would be replaced with the mapped value from the Zap.

Give that a try.

 

Userlevel 1

Troy you were right! 

Removing the space btwn the names of the attributes {{FirstName}} instead of {{First Name}} did work exactly as it should in the Template solution you suggested. 

Thanks for you help!

 

Side note: I was contacted by Zapier support saying that the formatting in my initial post is not something that should be occurring but that the developers were alerted to the issue and hopefully a solution will be made to that option as well. 

 

Reply