Best answer

Zap runs successfully but there is no data in Google Sheets

  • 9 November 2023
  • 5 replies
  • 141 views

Badge

I have a zap which connects jotform with google sheets.

While testing manually when jotform data is passed onto google sheets after some formatting using python code, it successfully enters that data into google sheet and I can open the sheet and see the data present there.

 

But when this zap run in production i.e when someone enters the entry into jotform and submits that zap triggers and runs successfully with no erros at all. but the catch is it just enters the timestamp into google sheet. apart from that no data is entered there in the sheets, everything is blank.

 

Has anyone faced this issue?

icon

Best answer by tusharbjobs 15 November 2023, 08:30

View original

5 replies

Userlevel 7
Badge +14

Hi @tusharbjobs 

Good question.

Check your Zap Runs history to see the DATA IN/OUT for each step to help you troubleshoot.

https://zapier.com/app/history/

Provide screenshots with how your Zap steps are configured along with examples of the DATA IN/OUT for the Zap Runs.

Badge

Here are the details and screenshots.

Also attaching the code I am using.

 

I did a quick test other way round. I created a duplicate action of insert step and removed all the data from the fields. Now inserted one field data coming from jotform trigger step directly in unformatted state and other field data in formatted step coming from the output of python code step in step 2. Both went again well on manual test run and both fields show up on google sheet in first case. But same story when triggered in production by submitting a form entry.

First field shows up the value on sheets coming from jotform in unformatted state, but second one coming from code step doesn’t show up on sheets.

 

Userlevel 7
Badge +14

@tusharbjobs 

 

Here’s why the Code step may not be working as expected, using an example…

The Zap Editor looks like the Jotform is returning JSON that is being used in the Code step.

 

The Zap Run DATA IN for the Code step looks like it’s being supplied with non-JSON.

 

Badge

So what do you suggest the best way to proceed on this?

If you can refer to my code attached I am getting the inputs like 

nyc_food_manager_matrix = input_data.get("nyc_food_manager_matrix")
The above one works well, but when I tried previously using zapier’s mentioned way to get the inputs like
nyc_food_manager_matrix = input_data["nyc_food_manager_matrix"]

it was erroring out. 

 

Is this related to accepting inputs at this step?

Badge

To anyone who is dealing with similar problem, this is a Zapier limitation. Zapier auto converts incoming JSON data as string when referenced that input inside the code step.

For more details here you can find the detailed information. 

 

So no code solution will work there. The only solution to this is use Raw webhooks and get the data in raw format then process that further in your code steps to do processing on JSON data.

Things are working for me now after using raw webhook instead of direct JotForm trigger. However, it took me a lot of time to figure that out and I would have appreciated if Zapier could document such limitations easily somewhere.

Reply