Question

Update Contact in Hubspot "Json node is missing child properties (HTTP Status Code: 400) Troubleshoot error "

  • 18 August 2023
  • 15 replies
  • 135 views

Hello everyone, I have the following challenge and I want to update an existing contact in Hubspot. Here I use Webhook by Zapier and as an action step "POST". However, I get the following error message "Json node is missing child properties (HTTP Status Code: 400)" I have already changed the payload type in "form" and "json", modified the code and checked in the JSON validator, recreated the token in Hubspot, but I can't get any further. The scopes I have selected in Hubspot to create a token are the following: "settings.users.read crm.objects.companies.write crm.objects.custom.write crm.objects.contacts.write settings.users.write settings.users.teams.write settings.users.teams.read crm.lists.read crm.lists.write crm.objects.custom.read crm.objects.contacts.read crm.objects.companies.read" Can someone please give me one or the other hint, what I can do differently?

 


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

15 replies

Hello @agileops, thanks for the answer. I don't quite understand the question. I go to HubSpot under API key, create a private app, give it a name "Update Contact", select the individual scopes as described: settings. users. read
crm. objects. companies. write
crm. objects. custom. write
crm. objects. contacts. write
settings. users. write
settings. users. teams. write
settings. users. teams. read
crm. lists. read
crm. lists. write
crm. objects. custom. read
crm. objects. contacts. read
crm. objects. companies. read. Let me view the token and copy it.

@Troy Tessalone thats the link for Update an existing contact. https://legacydocs.hubspot.com/docs/methods/contacts/update_contact

Userlevel 7
Badge +14

@Viktor 

Wonder if this is related.

Best to use the newest version of the API available.

 

@Troy Tessalone Thanks for the info, I will inquire at HupSopt Support

Hello @agileops @Troy Tessalone thanks for your help. Meanwhile, the Zap works but changes in Hubspot not the slightest. 
Tried it with both approaches (see pictures). Nevertheless, the Zap runs successfully but in Hubspot nothing changes. Do you happen to have any idea what this might be about?

Userlevel 7
Badge +14

@Viktor 

We would need to see updated detailed screenshots with how your Zap steps are configured.

Try removing any leading/trailing line breaks.

 

These are the individual steps @Troy Tessalone 

Userlevel 7
Badge +14

@Viktor 

Looks like you are still using v1 of the HubSpot API.

Try using v3 of the HubSpot API: https://developers.hubspot.com/docs/api/crm/contacts

 

Userlevel 1
Badge +1

Hi @Viktor ,

To be able to answer this question, could you share what is the HubSpot API that you are using?

Cheers,

 

@Troy Tessalone Here I replaced https://api.hubapi.com/contacts/v1/contact/vid/2340324/profile with https://api.hubapi.com/contacts/v3/contact/vid/2340324/profile and got the following error message "Error 404 Not Found (HTTP Status Code: 404)"  Then I found a section with Update Contact and tried these two URLs, but it gets one and the same error message "Error 405 Method Not Allowed (HTTP Status Code: 405)"

Userlevel 7
Badge +14

@Viktor 

Make sure to reference the HubSpot API docs.

Check the method which is different. (PATCH)

 

Userlevel 1
Badge +1

@Viktor 

Can you try this? 

 

  • OR another approach is 
    Select Custom Request event
  • Then for Data you can use 

Let me know how it goes!

Cheers,

Userlevel 7
Badge +14

Hi @Viktor 

Good question.

Looks like the Code step is not configured to properly output the desired value.

For example, the screenshot below will result in the value of Chef being enclosed in 2 double quotes.

{

"property": "jobtitle",

"value": ""Chef""
}

 

Thanks @Troy Tessalone, I reworked the code. However, I still get the following error message "Json node is missing child properties (HTTP Status Code: 400)"

Userlevel 7
Badge +14

@Viktor 

What is the link to the API documentation you are referencing to configure the API request step?