Google Docs Append says it works but don't append - Webhooks

  • 29 February 2024
  • 1 reply



i’m running a pretty complex zap which works basically like this:

  1. When it triggers it retrieves informations with Affinity API in a code step, then creates a Google Doc adding a short paragraph (with <p> tags) and change permissions to make it available to edit for the whole internet
  2. Then, it loops though each item of the json and for every item retrieves other infos with the code step and send this info to another zap through the webhook in step 8 (everything here works fine)
  3. The other zap, which triggers N times (where N is the number of items in the json, hence a list of names in my CRM) does a whole bunch of things that works EXCEPT the Google Docs append step that zap tells me it goes through fine but in reality it does not append

The problem is basically that say i have 5 loop iterations and i expect that all 5 goes through, which means i should have 5 lines in my doc. Well, Zapier tells me that the step works perfectly fine but when i open the doc i find only a partiaal result (say like 3 out of 5 line).

The zap has many other steps than the ones explained but it all works perfectly and they have nothing to do with this context.

What is wrong? I tried every possible solution, even removing all the HTML tags but it still doesn’t work fine




1 reply

Userlevel 7
Badge +14

Hi @mc_vento 

Please clarify which Zap version you are using as there are 2 shown. (DF1 and DF2)

The Zap Runs screenshot shows DF2.

The screenshot from Gmail doesn’t provide context about a generated GDoc contents.