Best answer

Can't get raw JSON from Webhook custom request (GET)

  • 10 August 2020
  • 3 replies

Userlevel 1

I need to get raw JSON from a Webhook GET request.  I’ve tried various options, and Zapier always parses the JSON, rather than allowing me access to it. (I’ve tried a simple webhook GET, and a webhook Custom Request GET)  I was able to get to the raw JSON in a different zap that used “Catch Raw Hook” as the trigger, but that won’t work for this new zap that I’m building.  Ideas?


Best answer by PaulKortman 23 August 2020, 21:56

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +10

@JonAtSHI You’re correct that it’s not possible to receive the unprocessed JSON with a webhook in Zapier. What are you trying to accomplish? Perhaps there’s another way around solving this?

Userlevel 1

Thanks @PaulKortman. I built a logging capability of sorts, to stash the raw JSON received from external systems received by Zapier, so that if there is ever an issue I have my own persistent log of the exact data received.  (retrieve the raw JSON via ‘Catch Raw Hook’, and stash it in a text file on a cloud drive).  This worked with something like the legacy WooCommerce connector, because I could have two Zapier feeds in WooCommerce, one for the zap that catches raw hooks, the other for the zap that actually processes the WC transaction.  Now that the new WC connector doesn’t use feeds, I’d like to recreate this by adding a Custom Get request in the zap that processes the WC transaction to request and grab the raw JSON and add it to the log.  I know I could still log the data by capturing it field by field, but that is subject to how Zapier parses the json, and is much more tedious to build.  

Userlevel 7
Badge +10

@JonAtSHI yeah I’m not sure of a way to make this happen… if the GET request didn’t need authentication you could use dropbox or google drive to create a new file and use the GET URL in the “file to upload” but neither of those services allow you to modify the headers of the GET request (required for authentication purposes). 


Sorry :(