Solved

How to fix formatting when creating Google Doc Template from Zap?

  • 16 October 2020
  • 4 replies
  • 35 views

Userlevel 1

When I create Google Docs from a template using Zapier, I continuously get strange formatting. There is an added line break after each variable which is placed in the document. 

All the variables are coming in which is great, but it’s quite annoying to have to go through and format the doc after it is created by the automation each time. 

Has anyone else had this problem or know how to solve it?

icon

Best answer by Troy Tessalone 16 October 2020, 18:39

Appears the data being sent in on the Webhook has line breaks for the data points. (see screenshot has extra rows before and/after the value)

Would need to run the data points thru a Code step to TRIM the extra whitespace (https://www.w3schools.com/jsref/jsref_trim_string.asp) OR Formatter steps to Trim Whitespace.

Also, might be able to fix the root cause in the system that is sending the webhook.

 

View original

4 replies

Userlevel 7
Badge +5

Make sure in the Zap there isn’t an extra line break in the field after where you are mapping the dynamic data point, which could result in the extra line break.

Otherwise, please provide screenshots of how your Zap step is configured and the originally populated GDoc template with the line breaks.

 

Userlevel 1

thanks @Troy Tessalone 

I have double checked for extra line breaks in the mapped variable fields. I can confirm that’s not the issue.

I shot this short video (I find videos way more useful than screenshots) that shows the configuration of the zap and the document being used: 

https://www.loom.com/share/f2be6ce2f9ff4459bbcf8edf5d85d414

hope that helps!

Userlevel 7
Badge +5

Appears the data being sent in on the Webhook has line breaks for the data points. (see screenshot has extra rows before and/after the value)

Would need to run the data points thru a Code step to TRIM the extra whitespace (https://www.w3schools.com/jsref/jsref_trim_string.asp) OR Formatter steps to Trim Whitespace.

Also, might be able to fix the root cause in the system that is sending the webhook.

 

Userlevel 1

thanks for your input on this @Troy Tessalone 

after further testing here, we did ultimately find a way to modify the system that is sending the webhook data. By trimming some html formatting there before passing to Zapier we’ve been able to fix this issue. 

Reply