Best answer

Zoom - Youtube Zap error: "Media type 'text/html;charset=utf-8' not supported"

  • 10 November 2021
  • 5 replies
  • 800 views

Userlevel 1

I recently have had all my zoom to Youtube zaps break…. 

anyone have any insights.  Here is the message I’m getting:  The app returned "Media type 'text/html;charset=utf-8' is not supported.".

icon

Best answer by jesse 11 February 2022, 21:58

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +12

Hi @michellepinkcallers 

So it looks like something has changed the Media type for Zoom recordings. I’m not really sure what could of happened but the Supported Media Types for Youtube can be found here: https://support.google.com/youtube/troubleshooter/2888402?hl=en

Can you post some screenshots of your Zap setup so that we are able to have a better understanding of what might be going on?

Thanks

Same problem. Does anyone has solved it already?

Userlevel 4
Badge +1

Hi all :raised_hand:

 

I came across the same issue today and I noticed that the Zoom APi is currently returning the video files as m4a.

 

As @GetUWired correctly noted, the YouTube API does not support that file format yet:

https://support.google.com/youtube/troubleshooter/2888402?hl=en

 

Unless the Zoom API can or will return one of the supported file formats and/or YouTube allows different file formats, there is not really a great way to automatically upload Zoom recordings to YouTube.

 

If anyone knows of a supported app integration that can transcode videos, feel free to share. Thank you!

This problem has 2 solutions.

 

1 - Make sure Zoom is recording only video format. In Zoom, go to Account management>Account settings>Recordings. Uncheck “Record an audio file only”

 

2- Make sure that your recordings are not locked behind a password. In the same menu, scroll down, and under Cloud Recording Downloads, make sure to “Allow anyone with a link to the cloud recording to download”. 

 

Now log out from your Zoom account, paste the link to the direct download in your URL and see that you can download the recording without password. If you cannot, record a new meeting, this time when “allow anyone..” setting is on.  If you are able to get the video without password, Zapier should handle it as well.

 

Userlevel 7
Badge +9

Hey @michellepinkcallers! It looks like someone else had a similar issue here, where one of our staff members posted a solution: 

Does this sound like it might be what you’re running into here?

I’d also love to acknowledge and quote some of the other great answers/advice in this thread:

 

As @GetUWired correctly noted, the YouTube API does not support that file format yet:

https://support.google.com/youtube/troubleshooter/2888402?hl=en

 

This problem has 2 solutions.

 

1 - Make sure Zoom is recording only video format. In Zoom, go to Account management>Account settings>Recordings. Uncheck “Record an audio file only”

 

2- Make sure that your recordings are not locked behind a password. In the same menu, scroll down, and under Cloud Recording Downloads, make sure to “Allow anyone with a link to the cloud recording to download”. 

 

Now log out from your Zoom account, paste the link to the direct download in your URL and see that you can download the recording without password. If you cannot, record a new meeting, this time when “allow anyone..” setting is on.  If you are able to get the video without password, Zapier should handle it as well.