Question

Zapier tables wont load new test data for trigger

  • 11 April 2024
  • 3 replies
  • 67 views

I have a simple zap im trying to create. I want to send an email based on an updated record trigger from my Zapier tables. 
I select the trigger column but when I pull the test records it only ever pulls the last three records in the table and those records are not even the ones I updated the trigger column on. 
if I try and move to the next step which is send a gmail email the trigger column is not showing up under my options for inputting into the email. 
It seems there is a disconnect between my table and the Zapier zaps as I can only get a portion of my zap to see the trigger column and it keeps pulling the last three records in the table. 

When I had this same zap setup on a google sheet it worked just fine. I have been migrating my data to Zapier tables for integration with interfaces for ease of use and didnt really see something this simple as being an issue. 

This is one of the final zaps I need to do to finalize this project and it is very frustrating for something so simple. 
 


3 replies

Userlevel 7
Badge +14

Hi @CoastalIS 

The Email field variable should still be returned to map between Zap steps so you can configure the Zap, to then turn it ON to test live.

Once you test live, check your Zap Runs history to see the DATA IN/OUT for each step to help you troubleshoot: https://zapier.com/app/history/

 

Or you can try adding an email address to 1 of the 3 returned records in the Zap trigger step to see if that will help you configure and test the Zap in EDIT mode.

 

NOTE: Zap app triggers only pull 3 MAX last records to use to configure action steps.

 

You can submit feedback to the Zapier Tables team here: https://eap.zapier.app

The problem with only pulling the last three records is that the last three records in my table do not have anything updated in my trigger column.
So I can not accurately setup the Zap if I cant pull the correct data from the actual trigger column. 
I will test run as is, and then circle back as you said. But if this is true for each time I set up a zap it's almost like a loop and seems not very efficient. 

Userlevel 7
Badge +14

@CoastalIS 

Did you try this tip?

Or you can try adding an email address to 1 of the 3 returned records in the Zap trigger step to see if that will help you configure and test the Zap in EDIT mode.

Reply