Question

Zapier is not generating google doc link

  • 14 February 2023
  • 5 replies
  • 39 views

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.

Hi Team,

Currently, I’m trying to copy a google doc and update the link in sfdc. Previously we have used Alternate Link to get the link but currently, it’s not providing the new link instead it’s generating the original file link.

Note: When I checked the drive file has been created successfully.

Zapier:

Salesforce Record Updation

 

Copying file:

 

Find File:

 


5 replies

Userlevel 7
Badge +11

Hi there, @Bsa Ops! 👋

How strange, that’s definitely not the expected behaviour here at all! I did some checking on this side but couldn’t spot any existing bugs around the Alternate Link being generated incorrectly. 

Can you please share a screenshot (Please remember to remove or hide any private information like names, email addresses etc from it first) from a recent run of the Zap that shows the Data In and Data Out for the Copy File and Update Record actions? Asking as I’d like to double-check what values are being generated and passed between those actions when the Zap is running live. I’m hoping that might help us to spot what’s causing this to happen.

Looking forward to your reply!

Hi Team,

Currently, I’m trying to copy a google doc and update the link in sfdc. Previously we have used Alternate Link to get the link but currently, it’s not providing the new link instead it’s generating the original file link.

Note: When I checked the drive file has been created successfully.

Zapier:

Salesforce Record Updation

Copying file:

Find File:

 

 

Hi @SamB ,

 

I’m posting the zapier logs. everything looks fine data in and data out looks like an alternate link broken

 

Userlevel 7
Badge +14

Hi @Bsa Ops 

Good question.

From the screenshots we can’t see the DATA OUT from Step 5 that includes the Alternate Link, and the matching URL DATA IN for Step 6 because it is blacked out.

Userlevel 7
Badge +11

Thanks for sending over those additional screenshots here, @Bsa Ops! 🙂

In the Data Out for the Copy File action we’re not able to see the alternateLink field in the screenshot. Could you please send over a screenshot of that field’s value (in the Data Out for the Copy File action) so we can see whether it matches the value that’s passed to the Update Record action?

Sorry to ask for more screenshots again here, but as we can’t look into your Zaps, they are really useful in helping to troubleshoot this. Thanks, we’ll keep an eye out for your reply!

Reply