Best answer

Zap not pulling in Form Data from Groovemail Form

  • 13 March 2023
  • 11 replies
  • 131 views

I am working on an integration of Groovemail Form to KW Command. The problem is Zapier is not connecting with the Groovemail Form, which includes fields - name, address and contact info (phone and email).

 

 

The form itself works in Groovemail and the data is going into the Contacts section of Groovemail. 

 

When I attempt to connect the Zap, all works well until we get to “Test Trigger”. Even though I have multiple form submissions, the test is only pulling in test data for email, first name and last name.

 

I have attempted trying to “load more data” and it’s not working. I’ve also discconected and reconnected the apps. I have also skipped the test, however while the test itself will work, zaps aren’t triggering when new submission are made. 

 

Can someone help? What do I need to do to connect it?

icon

Best answer by SamB 14 March 2023, 12:01

View original

11 replies

Userlevel 7
Badge +14

Hi @Monicabmh 

Good question.

Some things to try…

  • Submit another form and then try to load more trigger examples.
  • Some Zap apps only provide dummy data for the Zap trigger so you can configure the Zap.
  • You may have to turn the Zap ON, then test, and check the Zap Runs to see the DATA IN/OUT for each Zap step: https://zapier.com/app/history/

Hi Troy,

 

Thank you so much. I published the Zap despite not being able to pull the data, and I have submitted more test samples on the form. They are indeed going into Groovemail contact form, but the Zap is not being triggered, so there is no Data In or out in the Zap history. Zap history is pulling as blank and the zap is simply not executing. 

Userlevel 7
Badge +14

@Monicabmh

Check and test your Zap app connection here: https://zapier.com/app/connections

Hi Troy, TY. I keep testing. No change. Not sure if I should unpublish. I’ve sent about 4 test sample submissions.

 

 

Userlevel 7
Badge +14

@Monicabmh

Might be best to open a ticket with Zapier Support: https://zapier.com/app/get-help

 

 

Thank you Troy! Will do! I appreciate you trying!

Userlevel 7
Badge +11

Hey @Monicabmh! 👋

I did some checking on this end and looks like you’re running into a bug with the GrooveFunnels app where new GrooveMail submissions are failing to trigger Zaps. I’ve added you to the list of users being affected by this issue. I can’t give any ETAs on when it will be resolved but, we’ve got your details logged on the bug report so we’ll send you an email the moment it’s fixed! 

In the meantime, if you’re able to get an email notification sent to you whenever the GrooveMail form is submitted, as a workaround you could try using an app like Email Parser to trigger from the email notifications instead. Assuming those email notifications would contain all the necessary information that you’d want to pass over to Keller Williams Command that is. If you’d like to give that a try you can find out more about how to trigger a Zap using Email Parser here: Trigger Zaps from new parsed emails

Hope that helps! 🙂

Hi SamB,

 

I am experiencing the same problem. Is there a resolution for this ?

 

Please let me know as I need a client of mine’s notifications to work via Zapier.

 

I need to resolve this by tomorrow.

 

Thanks in advance for your help.

 

Regards

Mark A Mack

Userlevel 7
Badge +6

Hi @Digital Universe,

I’ve added you to the open bug report and are working with GrooveFunnels on a fix. We'll update you via email as soon as there's any progress. Unfortunately, we don't have a timeframe for the bug fix or any available workarounds at this time. I'm sorry, I wish I had a more immediate solution for you. It never hurts for you to reach out to the app developer directly and let them know you're running into an issue with their Zapier integration. We do notify them from our end, but a nudge from their users can sometimes carry more weight!

Hopefully, this helps! 😊

I am having the same problem. 

 

As a work around I embedded the Mailerlite form into my lead magnet page but then Groove does not show the thank you page after the form is submitted. So I am stuck with deciding what to do. 

Userlevel 7
Badge +9

Ah, sorry to hear you’re also running into this too @Doodle Therapy. I did add you as an affected user and we’ll email you once a fix is in place.

While I wish I had a better solution, I really appreciate you sharing your workaround with the community!

Reply