Best answer

WooCommerce connection won't reset or reconnect

  • 26 August 2021
  • 2 replies

I need a little help here guys. I made a video about the issue here;


Recap: I can’t get my WooCommerce account to reconnect. I am using my admin account and the owners admin account. I created Application Specific Passwords for both accounts and tried each, no joy. 

I am unable to get the “connection” -- which WORKED earlier today, to reconnect

I came in to edit a zap, and when it wouldn’t save, I exited, made a copy and tried editing the copy. Neither of them will “connect” to my WooCommerce account. I logged out of everything, logged into, my WordPress site at and Zapier (all using his account). 

As you can see from the video, I’ve disabled popup blocking, made an exception to Zapier’s site (just in case), tried three different browsers (FireFox, Chrome and FireFox Developers Edition), and all behave the same. 

Other important pieces of info: WordPress is latest version at 5.8. WooCommerce is 5.6.0, WooCommerce Zapier is 2.2.1, Zapier account is in good standing and not due for paid renewal until Sept 2022. 

Appreciate ANY suggestions. My customers Zap is no longer working and this one is important to him. Thanks in advance! 



Best answer by SamB 19 November 2021, 12:05

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +11

Hey @drbrotman,

It looks as though you had also reached out to our Support Team about this and they discovered a “Google reCAPTCHA verification failed. Do you have JavaScript enabled?” error in the logs.

It’s been a while now so I suspect you’ve already got this issue figured out but in case you or anyone else is having similar issues I thought I’d pop in here to share some tips! :)

This type of error can sometimes occur if the WordPress site is using a plugin, like WordFence for example, that utilises reCAPTCHA. Disabling reCAPTCHA on the site can help to allow Zapier to connect successfully. 

If that doesn’t do the trick, WooCommerce also have a helpful guide on how to troubleshoot different types of authentication issues which may be helpful: WooCommerce > Authentication Issues

I deactivated every single plugin (including recaptcha) on my site except for Woocommerce and still got this message. Does it work on version 7.5.1?