Best answer

Upload Slack files to OneDrive not working when channel selected

  • 19 September 2020
  • 6 replies
  • 435 views

Userlevel 1

Hi guys.

 

I’m trying this zap (https://zapier.com/app/editor/99671358?simple=true), which is already premade, to automatically upload Slack files to OneDrive. By default, it works great. The problem is that when you only want to upload those files from a specific channel (see custom option in the screenshot below), the zap won’t work. I checked the task log and it doesn’t even trigger. That doesn’t happen when no channel is selected.

 

I checked the following thread:

But the problem is not exactly the same. When testing the zap, it works. But then it won’t trigger when a new file is shared in the Slack channel configured.

 

Do you know what could be happening? Any workaround for this?

Custom option to only upload those files from a specific Slack channel

 

icon

Best answer by christina.d 15 March 2023, 23:17

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +14

Check this Slack Help article: https://zapier.com/help/doc/working-message-attachments-slack

Userlevel 1

Check this Slack Help article: https://zapier.com/help/doc/working-message-attachments-slack

Hi Troy, thanks for your answer. I checked for the option of treating the Slack file as a message attachment, but it doesn’t even appear among the Zapier-Slack options. The ones that I can see are the following:

 

1. Title

1. File (Exists but not shown)

1. User

1. Filetype

1. URL Private Download

1. Pretty Type

1. Permalink

1. Size

1. ID

1. URL Private

1. Created

1. Permalink Public

1. Is Public

1. Mimetype

1. Comments Count

 

Is this something that simply cannot be done? Again: when no channel is selected, it works great. The problem is when filtering by channel.

Hi there @amarlop , have you found a solution for this? I’m running into the same issue (trying to upload from Slack to S3), trigger with file upload works when testing, but doesn’t trigger at all when the Zap is live.

 

Thanks

Userlevel 7
Badge +8

Hi there @amarlop , have you found a solution for this? I’m running into the same issue (trying to upload from Slack to S3), trigger with file upload works when testing, but doesn’t trigger at all when the Zap is live.

 

Thanks

 

Hi there @60d - Sorry to say that you’ve run into a bug. I’ve added you as an affected user to the bug report so that the team understands to look at this.

A possible workaround: If you are triggering off relatively unique messages, is to use a Find Message search action and do an exact text search (in quotation marks) for the message that triggered the Zap—that will return the attachment info they need.

Userlevel 7
Badge +14

You can filter by Channel ID in a Filter step after the trigger step if need be.

 

Userlevel 7
Badge +9

Sorry to say that you’ve run into a bug. I’ve added you as an affected user to the bug report so that the team understands to look at this.

Hey friends! 👋🏽I wanted to swing by with a belated update!

A fix has been launched and the “New Message Posted in Channel” trigger now includes attachment info for bot messages.🤖 🎉

The caveat being any attachment info from a human message will still require the workaround. My pals in docs created a tutorial for this though.

Thanks for your patience and happy zapping!⚡️