Best answer

unreliable triggering when a new data record is added to the table.

  • 21 August 2023
  • 6 replies
  • 78 views

While using Zapier, I've noticed that a ZAP is not always reliably triggered when new data is added. It seems that the triggering of the ZAP is inconsistent and may depend on various factors, such as the timing or a specific email in a field of the table. Even when I create a copy of the data record, the ZAP is not always activated, although doing so seems to increase the likelihood of it being triggered. I'm looking for a reliable solution where adding a new data record consistently triggers the ZAP. Can you assist me with this?

icon

Best answer by SamB 6 October 2023, 15:29

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 6
Badge +6

Hi @JC LECL ,

 

Can you please share a screenshot of your Zap? 

Userlevel 7
Badge +14

Hi @JC LECL

Can you please clarify which apps you are using in your Zap steps? (screenshots)

Airtable may be a better solution than Zapier Tables.

Hi @Troy Tessalone and @jayeshkumarbhatia 

The Zap sometimes doesn't trigger. I can't discern any pattern. I'm using Zapier Table. On the screen, you can see empty cells. Those are the times when it didn't trigger. Thank you for your support.

Userlevel 7
Badge +14

@JC LECL 

You may want to try submitting a ticket to the Zapier Tables team: https://eap.zapier.app

@Troy Tessalone Done! Thank you! JC

Userlevel 7
Badge +11

Hey folks! 👋

Just wanted to hop in here with a quick update for anyone following this read. The Support team responded to @JC LECL and it’s now working! It appears the problem was that the Zap wasn’t using the latest version of the Zapier Tables app and updating the Zap to use the latest version resolved the issue. 😁🎉
 

Seems like everything is all set for now but please do reach back out to the Community if you ever need help with your Zaps - we’re always happy to assist!