Best answer

Troubleshooting Mailjet Zap with Variables Not Updating from Google Sheets

  • 23 September 2023
  • 11 replies
  • 167 views

Userlevel 1
Badge

i have a Zap set up to send an email via Mailjet with a Mailjet template. I am using variables in the Mailjet template to receive the data from Google Sheets. When I test the step everything fires and I receive the email, but the variables just show the default data and not the data from Google Sheets. The zap is passing data because I pass the “First Name” of the record into the subject of the email. When I receive the test email I the subject has the “First Name” of the record from Google Sheets.

icon

Best answer by Eric S. 3 October 2023, 19:41

View original

11 replies

Userlevel 7
Badge +14

Hi @Eric S. 

Good question.

We would need to see detailed screenshots with how your Zap steps are configured to have more context.

Userlevel 1
Badge

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.

Userlevel 7
Badge +14

@Eric S. 

Check your Zap Runs history details to see the DATA IN/OUT for each Zap step to help you troubleshoot: https://zapier.com/app/history/

Showing more screenshots of that data will help us have context.

Userlevel 1
Badge

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.

Here you go.

 

 

Userlevel 7
Badge +14

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.

@Eric S.

Show screenshots of the DATA OUT from the Zap Trigger step.

Some variables are empty/missing/blank/null in the DATA IN for the Zap action step.

 

Userlevel 1
Badge

It is included in the last message. It’s the last screenshot in the message. A couple of the variables don’t have data because there is nothing in those fields for that particular record. 

Userlevel 7
Badge +14

@Eric S. 

Show screenshots of the DATA OUT from the Zap Trigger step.

The screenshots you provided are from Step 3, not Step 1, which is the trigger step.

If there is no DATA OUT from Step 1 for certain fields, then that explains why there is no DATA IN for Step 3.

Userlevel 1
Badge

 

 

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.

Please note Col$C is the Account Name and should be passed to the Mailjet variable. Also, I know the Zap is pulling data from the spreadsheet and sending some of it to Mailjet because in the set up of the Zap to send the data to Mailjet I use the First Name of the record in the Subject line. That information is coming through in the test emails. It is specifically the information going to the Mailjet variables that is not working.

Userlevel 7
Badge +14

@Eric S. 

It may be that your template variables are not configured correctly IN the Mailjet Template.

 

Userlevel 1
Badge

I contacted Mailjet support. They gave me guidance on the variables and how they should be set up on the template. It’s not intuitive, but it worked. When written like this {{var:acctname:"no acct name"}} where acctname is the name of the variable you enter in the field in Zapier the data transfer works. 

Userlevel 7
Badge +11

Pleased to hear the Mailjet team were able to get this solved, @Eric S.! 🎉🎉🎉

Thanks so much for taking the time to pop back in here and share details of the solution you found with them. It'll help a lot of folks out there facing the same issue. Seems like your Zap is all sorted for now, but please do reach back out to the Community again if you run into any further issues or questions - we’re always here and happy to help! 🤗

Reply