Question

Surveymonkey test says 'no data' for email_address even though I know an email address was collected

  • 17 November 2023
  • 1 reply
  • 106 views

I am trying to build a zap with Surveymonkey as the trigger and sending a Giftbit reward as the action. The survey asks for participant’s contact information and my test response included an email address, but when I test the trigger ‘email_address’ is blank. I need the email address data to be pulled in order for my Giftbit action to work.

Do I need to tell zapier which question to find the email addresses in? How can I do that?


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Userlevel 7
Badge +14

Hi @Melissa at Uplift 

Good question.

Help: https://help.zapier.com/hc/en-us/articles/8495939619853-Common-Problems-with-SurveyMonkey#i-m-getting-an-error-telling-me-i-need-to-upgrade-my-survey-monkey-plan-to-an-annual-subscription--0-0

I'm getting an error telling me I need to upgrade my Survey Monkey plan to an annual subscription.

The "New Response Notification with Answers" trigger will require you to have any Annual paid plan with Survey Monkey. This includes the Standard Annual, Advantage and Premier plan, which are all annual subscription plans that Survey Monkey offer. This information can be found here: https://help.surveymonkey.com/articles/en_US/kb/SurveyMonkey-Partner-Integrations-Changes

The only paid plan that doesn't work with Zapier integrations is their Standard Monthly plan, which is their only monthly subscription plan.

The Email or Name Fields Are Empty

SurveyMonkey responses have three default fields, Email, First Name, and Last Name. Those will only be populated from your SurveyMonkey address book if you are using an email collector. If you have a question on your survey that asks for their name or email, use the Responses field for that question when you match up the fields.

Respondent ID Is the Only Appearing Field

If your Survey responses fields are not showing up when you are setting up your Zap, you might need to submit or refresh some sample data.

To fix this, simply submit a brand new survey response and fill in an answer for every single question. Once you have submitted that, head back to your Zap and you should then be able to find these.

Some Fields Not Appearing

Do your fields have exactly the same name? If you have more than one question that is exactly the same, we will only see one of those. To resolve this you will need to make sure all of your questions on your survey are unique. If they are and you are still having some trouble, please don't hesitate to get in touch, we're happy to help!

Easy - these tags just need to be typed into the Message Body field and when we send this to SurveyMonkey's API, they will automatically populate the respective links where the tags were added within the Survey that is Sent!