Best answer

SurveyMonkey error: Unable to pull response. You have not authorized Zapier to "View answers along with responses"

  • 14 September 2023
  • 6 replies

Userlevel 1

Hi I’m getting following error while connecting with survey monkey. My connection is fine and I have yearly account on surveymonkey and enterprise google workspace



Best answer by syed.ali 15 September 2023, 14:18

View original

6 replies

Userlevel 7
Badge +14

Hi @syed.ali 

Good question.

Help article:


I'm getting an error telling me I need to upgrade my Survey Monkey plan to an annual subscription.

The "New Response Notification with Answers" trigger will require you to have any Annual paid plan with Survey Monkey. This includes the Standard Annual, Advantage and Premier plan, which are all annual subscription plans that Survey Monkey offer. This information can be found here:

The only paid plan that doesn't work with Zapier integrations is their Standard Monthly plan, which is their only monthly subscription plan.




Userlevel 1

Hi @Tory

Thanks for your response. I already have the yearly plan with survey monkey. 

Userlevel 7
Badge +14


Did you follow the instructions in the encountered error?


Userlevel 1


Yes, I removed SurveyMonkey from App & Event and added it again but it didn’t ask me for the permission. I did same even with the new Zap.

Userlevel 1

Hey Troy,

So I went to the apps and removed the connection and added again. My bad didn’t tried earlier. Now it is working thanks for the support. 

Userlevel 7
Badge +11

Thanks so much for circling back here to share how you solved this, @syed.ali. Really pleased that removing and re-adding the Survey Monkey connection did the trick! 🎉

Sounds like you’re all set for now but if you need further help with anything else Zap-related please do reach out again - the Community is always here and happy to help! 🙂