Question

Squarespace Forms to Notion Database: Items not going through HELP!

  • 4 February 2024
  • 13 replies
  • 87 views

Userlevel 1

I’m trying to use the simple zap of Triggering a New Form Submission (in Squarespace) to make an Item Entry in a database (Notion).


I’m beside myself because I can’t figure out why it won’t work. Can someone look at what I’m doing and tell me what I’m missing?

Zapier Process:

  1. App & Event: Squarespace: New Form Submission (green check)
  2. Trigger: “Attend a Virtual info Session Form” (green check
  3. Test: We found records in your Squarespace account. (I have selected the right record) (green check)
  4. App & Event: Notion: Create a Database Item (green check)
  5. Action: Database “Info Session RSVP” (I’ve connected all the fields in the Notion database to corresponding fields in the Squarespace Form) (green check)
  6. Test: Send Database Item to Notion (Zapier makes up an entry for John Smith and it sends perfectly -- goes right into the database)  (green check)
  7. Publish (done. The zap is on)

Squarespace:

When I go into the Squarespace form from my website builder interface, I can confirm that the zap is connected. I get a message saying it’s connected and a little green bubble beside the text

 

Everything seems good. HOWEVER, when I go to the active Squarespace website (NOT the builder interface) and submit the form (Attend a Virtual info Session Form) - the contents do NOT show up in the Notion database (Info Session RSVP).

 

Any ideas?

I have screenshots of all this. If any screenshots are helpful


13 replies

Userlevel 7
Badge +14

Hi @Julia Cordero 

To help us have full context, post screenshots with how your Zap steps are outlined and configured, thanks.

Userlevel 1
 
 

 

 

 

 

 

Userlevel 7
Badge +14

@Julia Cordero 

Check your Zap Runs for activity/errors: https://zapier.com/app/history/

In Squarespace, try disconnecting then reconnecting the Form.

 

Help: https://zapier.com/apps/squarespace/help

 

Does the app need any special plan pricing?

To use Zapier with Squarespace, you must be on the Website Business plan or higher. To learn more, visit their Premium features page.

 

My form doesn't appear in the Zap's dropdown menu

Zapier can only receive data from Form and Newsletter blocks in Squarespace. Forms created as part of a Cover Page or a product order are not supported.

As a workaround, you can configure other form types in Squarespace to use Google Drive or an email address as its storage. You can then trigger your Zap using the Google Sheets or Email Parser integrations.

miscEye icon Note

If your form is within a Form Block and doesn't appear in the dropdown, delete and recreate it within your Squarespace site. It should then appear when you refresh the Zap's dropdown menu. 

Userlevel 1

@Troy Tessalone 
 

I’m on the business plan for squarespace. And my form “appears” fine in the Zap configuration (It’s the one listed above as “Attend Virtual Info Session Form.” 


I checked the activity/errors link you sent -- and there is no activity to show that it has gone through at all - so there isn’t even an error -- because it’s just literally not there. Despite the fact that I’ve submitted a new form several times. Do you have any clues as to what that could mean?

Userlevel 7
Badge +14

@Julia Cordero 

Did you try this?

In Squarespace, try disconnecting then reconnecting the Form.

Userlevel 1

@Troy Tessalone 

I also disconnected the zap from squarespace (meaning, within my zap, I connected it to the gmail app instead and then switched it back to squarespace - where I had to reconnect to the exact form in squarespace (“Attend Virtual Info Session Form.”)

Still no luck. I am so perplexed. And really frustrated.

Userlevel 1

@Troy Tessalone Apologies. Let me see if I can figure out how to disconnect IN SQUARESPACE

Userlevel 1

No dice.

I pressed the “DISCONNECT” button in squarespace. It changed from “2 zaps connected” (as I also have it set up to send a confirmation email through zapier - which is working fine)  to “awaiting connection.”

 

Then I went back into Zapier and re-connected the form again.

 

Wait - is it because I have 2 zaps connected - both of them are triggered by “form submission.” And they are 2 separate zaps. Again - the first one is working fine (sending a confirmation email)

Userlevel 7
Badge +14

@Julia Cordero 

Try using 1 Zap per SS Form.

@Julia Cordero Have you had any luck with the automation since. I am experiencing the same issue and cannot seem to find any information on how to resolve it,

Userlevel 7
Badge +14

@Julia Cordero and @Kaela 

If you need help, consider hiring a Certified Zapier Expert: https://zapier.com/experts

Userlevel 1

@Kaela I think the thing that worked was to just have 1 automation triggering. I had two going at the same time (one to send an email confirmation to the person who just registered and another to put the data into a table in notion). I bypassed this issue by leaving the first automation in place (confirmation email). Then I set up the Squarespace Form to autopopulate into a google sheet (which squarespace is set up to be able to do on its own - didn’t need zapier for this). Then I set up a zapier automation to move the data from the google sheet to a notion database. That way ONE automation was triggering from the Squarespace Form (email confirmation) and ONE automation was triggering from the google sheet. I think the problem was having the FORM itself have TWO triggers. That’s my guess, at least. My workaround is working fine for me.Good luck

Hi Julia, thank you for your reply, I ended up having the do the same thing. It’s quite a shame they can’t run simultaneously but atleast they are working. Thank you!

Reply