Question

Slack Zap isn't triggering for thread replies, even though the thread_ts ≠ ts filter is applied.

  • 2 November 2023
  • 5 replies
  • 115 views

Hi there, 

I’m trying to count a thread messages only. I know i can filter thread messages by filtering  
thread_ts ≠ ts

 

But the problem is that the trigger “New Messge posted to Public Channel” doesn’t seem to be activated when i post replies in a thread.
I’ve made sure to use a public channel, add zapier, etc.

 

Could this be due to the fact that the “root message” is a bot from workflow builder?

 

 

 

 

 

(don’t mind the next steps, here i’m only checking the first one)

 

 

Thanks a lot for your help!


5 replies

Userlevel 7
Badge +14

Hi @Babz 

Good question.

Make sure to enable the Slack trigger setting to trigger for bot messages.

 

Yeah yeah, the issue is that it only triggers on bot messages, not humans replies in thread (i tried with the various settings in the trigger, no impact)

Userlevel 7
Badge +14

@Babz 

The field description for “Trigger for Bot Messages?” would include bot messages, and not limit to only bot messages.

 

yes, this is why my current parameters should work right?

trigger for bot message = YES

i expect my zap to be triggered on both:

  • bot messages (root messages) → currently working ✅
  • human messages (thread replies) → not working ❌
Userlevel 7
Badge +11

Hi @Babz! 👋

Setting the Trigger for Bot Messages? field to Yes (true) should indeed allow the Zap to trigger for both bot and user messages.

Did you switch the Zap on and found it wasn’t triggering for new replies in a thread? Or are you just finding that you’re unable to load the replies in as new test records?

I’ve double-checked in my on Zaps and if the Zap is switched on, replies in a thread will trigger the Zap. But, replies in a thread are not pulled into the Zap Editor when attempting to load a new test records from Slack.

Also want to note that when the Zap runs live the Thread Ts field will not be present for the “parent” message for the thread - despite this field being available to select in the Zap Editor. When the Zap is switched on the Thread Ts field would only be present for the replies in a thread.

Looking forward to hearing from you!

Reply