Best answer

Slack workflow error: An error occurred executing a workflow step you own. Check out your workflow for further details.

  • 2 November 2022
  • 2 replies

I’m trying to trigger an email to send within the Slack Workflow builder. I’m using Zapier’s “Send Email with Gmail” feature. The test shows no issues, but when I run the Workflow, it results in this error: “An error occurred executing a workflow step you own. Check out your workflow for further details.”

I have replicated the functionality as a standalone Zap created in Zapier and triggered by an emoji reaction within Slack. This works. 

I have tried Slack’s help, and their response was that they don’t maintain the Workflow steps built by other apps, like Zapier. 

How can I troubleshoot here?


Best answer by christina.d 2 November 2022, 21:23

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +9

Hey there, @kc-dev! Thanks for raising this in community!
I can see you reached out to support and I wanted to share their response in case you hadn’t received the email:


After looking over your account, it looks like this error may be happening due to Zaps associated with the Slack Workflow being in the trash.
Can you try moving the Zaps from the trash to another folder and let me know if the issue persists or not afterward?


If you're not seeing a response, it might be worth checking your spam/junk folder in case it’s ended up there by mistake.  If it's not there I recommend searching your whole email inbox for emails ending in ‘’.

Keep us in the loop if this works for you! 🙂

Thank you! For whatever reason, this seems to appear in the Zapier trash on creation. Relocating the file has resolved the issue.


I will check the spam for the email reply, but I’m glad to have resolved the problem.