Best answer

Odoo Online/Odoo.sh “authentication failed” error

  • 5 June 2023
  • 3 replies
  • 111 views

Userlevel 1
Badge

Hello, I am experiencing a problem connecting to the Odoo CRM application.

I have made several attempts, but it is not working even though my credentials are correct.

I am using version 15 of Odoo hosted on Odoo.sh. Do you have any solutions to offer me?

 

icon

Best answer by Sekh 6 June 2023, 12:14

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +9

Hey there, @Sekh

Thanks for sharing those details! I did some digging and it looks like you’re using odoo.sh which isn’t supported at this time. While I don’t have an ETA on when or if this will be implemented I did add your vote to an existing feature request. This is the best way to stay informed if anything changes as we'll email you if this does go live.

There’s also a main thread where we’ll be sure to announce any changes:

Sorry to not have better news here but definitely appreciate you flagging this in community!

Userlevel 1
Badge

 

Thank you for your response.

Here is a solution I found on the Odoo forum that works for me.

 

First, you need to add a specific custom domain alias to allow Zapier to understand the actual name of the database.

More concretely - follow these steps : 

  • 1/ Odoo.sh -> Select the production branch -> go in the shell
  • 2/ Copy the name of the database "mydatabase-main-XXXXXXX"
  • 3/ Go in the  "setting"  tab.  Create  a  new  domain  allias  by pasting  this database name e.g. " mydatabase-main-XXXXXXX.odoo.com"
  • 4/ In the zapier settings (for connection) - please use this new database domain to get connected. 
Userlevel 7
Badge +8

Thank you so much for coming back with a solution for this. I’m sure it will be of great use to future users! 😁