Question

Missing Data and Date Format Issue in WooCommerce to ActiveCampaign using Zapier

  • 16 November 2023
  • 5 replies
  • 34 views

Userlevel 1

Hi everyone,

Two questions regarding setting up a one-time transfer between two apps (WooCommerce → Active Campaign.

  1. I have a field for which Zapier can draw and preview the data during the mapping stage, but when I do final review of the entire data set, the field is empty. What could be going wrong?
  2. One of the fields is a date field. How can I reformat the date for the receiving app, similar to how one might do so in a normal zap using Formatter by Zapier?

For my first question, I’ve connected the apps and run through the steps to set up the steps. In the initial mapping, Zapier sees and can assign the correct field, which holds text data. (see below)

Next screen, when I preview my mapping, Zapier shows the data in this field successfully. See below with highlight of the sample results in red.

(I’ve also shown in red the date format that I’d like to change to YYYY-MM-DD format.)

So far so good. However, when I go next to where Zapier pulls the data set, this subscription type field pulls no data. Most other fields pull data successfuly. Only this and a couple other meta data text fields don’t pull.

So, what could be preventing Zapier from pulling this data, when it could see it initially?

Thanks in advance if someone can guide me here. (Also, much appreciated for any tips on date formatting, in this situation.)


5 replies

Userlevel 7
Badge +14

Hi @Katie Glassman 

Good question.

 

(I’ve also shown in red the date format that I’d like to change to YYYY-MM-DD format.)

Instead of using a Transfer, you would need to configure this as a Zap to add a Formatter step to change the format of the date.

Userlevel 1

Hi @Troy Tessalone thank you for your reply once again.

If I understand you correctly on the date format issue, then it seems Transfers are unable to change format. Ok, good to know! (I’m using a transfer to send existing, non-triggerable data, so a zap won’t work in this case.)

I appreciate the advice. If you, or anyone else, has suggestions on my primary issue of data not transferring, I remain open to them.

Userlevel 7
Badge +14

@Katie Glassman 

You may want to consider doing a manual export/reformat/import from WooCommerce to ActiveCampaign.

Userlevel 1

@Troy Tessalone Excellent suggestion. Trouble is, I haven’t found a way yet to export my data from WooCommerce. Woo doesn’t make it easy at all to download/export subscription data. 

Thanks.

Userlevel 7
Badge +14

@Katie Glassman 

Check this help article:

https://woo.com/document/import-and-export-of-woocommerce-subscriptions/

Reply