Question

Invalid Lead ID: One or more of your Lead IDs are invalid or have been deleted.


I’m trying to set up Active Campaign integration with Facebook and I keep getting this error message in the 2nd step:

Invalid Lead ID: One or more of your Lead IDs are invalid or have been deleted. Your entire batch of events can be rejected if there are one or more invalid Lead IDs. The Lead ID is a unique 15-16 digit number generated by Meta. 

I’ve used the ID from the events manager and I don’t know what else to do


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

8 replies

Userlevel 7
Badge +11

Hi @SallyWade, welcome to the Community! 🙂

You mentioned that you’ve used the ID from the events manager is that a 15-16 digit number? If not, it might be that it’s not the ID for the lead but for the event? Do you think that could be the case here?


That said, the error says it can reject the whole batch of events if one of the lead IDs is incorrect so can you try leaving that field blank (assuming it’s not a required field?) to see if that then allows the Facebook Conversions action to create a new ID for it? Just wondering if that might help to get around the error and ensure that the rest of the events in the batch won’t get rejected as well.

Looking forward to hearing from you!

I’m trying to set up Active Campaign integration with Facebook and I keep getting this error message in the 2nd step:

Invalid Lead ID: One or more of your Lead IDs are invalid or have been deleted. Your entire batch of events can be rejected if there are one or more invalid Lead IDs. The Lead ID is a unique 15-16 digit number generated by Meta. 

I’ve used the ID from the events manager and I don’t know what else to do

 

We ran Facebook lead ads since November of last year and everything worked fine until the end of May (19th-23rd or so) when we began having a ton of these errors.  We have yet to identify the problem.  Some of our stage changes work just fine, then others fail.  We have tried deleting our connection to Zapier and re-add it, we’ve tried recreating all of the Zaps.

We’ll have a lead go through, for example, 4 stages of our funnel without a problem, but on the 5th and 6th stages it’ll fail with that invalid lead id, while others will make it all the way through.  There simply is no rhyme nor reason why some work and some do not. 

I know that Facebook recently switched over from Pixels to Datasets in May and this was what we originally thought the problem was related to.  We have tried contacting Facebook but they haven’t been any help at all.  They say everything should be just fine and have yet to been able to provide a solution.

Have you had any luck figuring out what the issue is?

Userlevel 7
Badge +6

Hi @wonders83,

I’m jumping in to see if I can help!

I did some digging into the error in our notes, and here’s what it says:

One customer was using the “Send Funnel Event” action to convert an existing lead. But, every once in a while, they hit this error:

Invalid Lead ID: One or more of your Lead IDs are invalid or have been deleted. Your entire batch of events can be rejected if there are one or more invalid Lead IDs. The Lead ID is a unique 15-16 digit number generated by Meta.

They discovered that the lead was older than 90 days. Facebook leads will expire and be automatically deleted after 90 days per this Meta help guide: https://www.facebook.com/business/help/1526849577619206?id=735435806665862

Hopefully, this helps! 😊

Hey Ken, sorry I missed your response somehow!  I’m still actively seeking a solution, in fact, I just opened a support ticket on Saturday and provided a ton of examples, I’m not sure if you’re able to take a look.  All I received is a confirmation from the Zapbot saying you received my message via the contact form.  

Unfortunately the 90 day issue isn’t our problem.  All of our leads have all been generated and moving through the funnel stages within a few weeks.

I really appreciate your help in trying to get this resolved.  

Userlevel 7
Badge +6

Hi @wonders83,

If you're still experiencing issues, our Support team needs to conduct a thorough investigation of your Zap and its logs to know the root cause of the issue. Our Support team is the best resource for this, as they have the necessary tools and expertise to examine your Zap and its logs.

You can reach out to our Support team by visiting this link: https://zapier.com/app/get-help.

They'll be more than happy to assist you further and get to the bottom of the issue. Let me know if there's anything else I can do to help!

hey @ken.a,

As I mentioned in the previous post I submitted an extremely detailed support request on Saturday but I have yet to receive any response.  How long does it take for someone from your support team to reply?

 

Thanks

Hi @ken.a,

What is the best way to get in touch with Zapier regarding my ticket?  Just reply to the automated confirmation response?  I wasn’t provided any type of ticket or case ID.

Today is day 5 since I submitted the ticket and I’ve yet to receive any response.

Thanks

Userlevel 7
Badge +6

Hi @wonders83,

I noticed that our Support team has sent a response to your ticket. I truly apologize if it took a while for them to get back to you. They've been handling a high volume of inquiries and are doing their best to provide timely and effective assistance to everyone.

Thank you for your understanding.