Question

Hubspot error: Required field "Role" (dropdown) is missing.

  • 25 October 2023
  • 7 replies
  • 47 views

I am looking to have forms that are submitted in a Zapier interface form be duplicated and submitted to Hubspot. I have set up two versions where:

 

  • 1. Form Submission Created in Zapier Interfaces → 2. Create Form Submission in HubSpot
  • 1. Form Submission Created in Zapier Interfaces → 2. Create Record in Zapier Tables → 3. Create Form Submission in HubSpot

 

I am able to get the Zapier form data to populate within the Zapier table, but keep running into errors when transferring the data across to Hubspot. The form data does not submit to Hubspot and I am also unable to get dropdown field data to populate at all.

 

Please advise! Thank you in advance.


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

7 replies

Userlevel 7
Badge +14

Hi @BSP 

Good question.

Please post screenshots with how your Zap steps are configured along with any encountered errors.

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.

 

Action for the Hubspot event, I also tried it where all the fields were ‘Form Submission Created in Zapier Interfaces’ and had the same results where no form was created in Hubspot.

 

Userlevel 7
Badge +14

@BSP 

Error:

 

Mapped variable for Role has “No data”.

 

@Troy Tessalone I have tried variations with that, as well as pulling from form submissions which DO have data because the field is filled in. But the role field never pulls any of the form data. It may be an issue with Zapier not reading dropdown field data.

@Troy Tessalone Additionally, the Role field is not a required field on the form, so even if it is empty, the user should still be able to submit it. The zap should still go through and create and submit a duplicate of the Zapier Interfaces form to Hubspot.

 

 

Userlevel 7
Badge +14

@BSP 

You can try submitting a ticket to the Zapier Tables/Interfaces teams:

https://eap.zapier.app

https://eap.zapier.app/interfaces

Userlevel 7
Badge +14

@BSP 

The HubSpot step shows the Role field is required, so that may need to be adjusted in HubSpot.

If you think that’s an issue, then you can submit a ticket with Zapier Support: https://zapier.com/app/get-help