Question

HELP: Failed to create a contact in HubSpot resource not found

  • 10 December 2023
  • 4 replies
  • 47 views

I am running test on an integration between MailerLite and Hubspot. I have assigned all fields to their corresponding in Hubspot - but upon test, it fails. and give the following message: 

 

Failed to create a contact in HubSpot

resource not found

 

Not sure what to do. Need help please.

 


4 replies

Userlevel 7
Badge +6

Hi there @Happy Giant,

Welcome to the Community! 🎉

Before we dig deeper into this, would you mind sharing a detailed screenshot of how your Zap is configured? Could you also please send a screenshot of the “Action” section of your action step? Here’s an example screenshot:

46dd6c0979e3d815d621b8da43084ef1.png
(view larger)

Please don't include personal information in the screenshot, or be sure blur out any personal information.

Thanks!

 

@ken.a hello, shared above.

Userlevel 7
Badge +6

Hi there @Happy Giant,

Thanks for the screenshots!

It looks like the issue here is the mapped data on the “Object ID” field:

667e9a3a8e72f578c60639203cb89b23.png
(view larger)

The “Object ID” field looks for the HubSpot contact Object ID. Are you using the “Update Contact” action here? If so, you’d need to add the “Find Contact” action before the “Update Contact” step, then map the Object ID or Record ID from the “Find Contact” step to the “Object ID” field in the “Update Contact” step.

Please give that a try, and let me know how it goes.

Reply