Best answer

Google Docs error: The user does not have sufficient permissions for this file.

  • 11 September 2023
  • 2 replies
  • 114 views

Userlevel 1

I set up a Zap action with Google Docs ‘Create Document from Template’. I do have all permissions and am the creator of the doc. 

 

When testing the zap, I get this error: “The user does not have sufficient permissions for this file”.

 

Oddly enough, the new document gets created, it’s just that the test in Zapier fails! But I need a successful test in order to use outcomes of this step in subsequent actions.

 

I have checked similar posts and tried things such as
- deleting and re-creating the step entirely
- choosing ‘target folder’ first, only then choosing the source template

None of this has worked. 

icon

Best answer by bennofatius 11 September 2023, 13:00

View original

2 replies

Userlevel 1

In case anyone else runs into this issue: clearing the preference in “Sharing Preference” solved this. 

Userlevel 7
Badge +6

That’s great news @bennofatius! Glad to know you were able to get it sorted!

Also, thank you for sharing the solution here. This will be helpful to our other amazing Community members who might run into a similar issue.

If you have any other questions, please don’t hesitate to reach out to the Community. We’re always happy to help! 🤗

Reply