Best answer

Getting an error when testing my Zap saying there is no email even though I have selected the email field

  • 15 August 2022
  • 3 replies
  • 23 views

Hi All! I am trying to integrate my Square Account new customers to a Klavyio list. Every time I test it I get an error saying there is no email even though I have selected the email field . Please help!

 

Thank you 

icon

Best answer by EJR 16 August 2022, 07:10

View original

3 replies

Userlevel 7
Badge +14

Hi @AmandaN 

Good question.

Please post detailed screenshots with how each of your Zap steps is configured in order for us to have more context, thanks.

Badge +3

Hi @AmandaN,

Welcome to the Zapier Community! Happy to help here.

Email addresses are usually unique identifiers for most apps and therefore it’s common that the email address is a required field. If the email address isn’t present when the Zap runs (or when you test the step), it usually presents an error and I think that’s what happening here in this case.

If you are just testing the Zap and you are encountering an error in your trigger step, it’s perfectly fine to skip the trigger testing as long as you have mapped the email field correctly. 

It looks like you have reached out to Support and one of our teammates already replied to your ticket. 

Since the solution to your concern requires a few steps to be completed on your end, I recommend continue working with Support via that email conversation that you opened with them. 

If there's anything else I can assist you with, please don't hesitate to reach out.

Userlevel 7
Badge +9

Hey there @AmandaN! I wanted to stop in and see if you were able to get this sorted? 

Keep us posted, we definitely want to make sure you’re all squared away here! 🙂

Reply